Cannot update Anki Desktop

I’ve got a weird problem. I run sudo ./, everything is success yet I still get “do you want to update window” on startup, and I open the help window, I discover Anki is still in 2.1.40, and hasn’t updated itself since! even though I distinctly remember installing a version after 2.140!

I download 2.1.40 package, run the uninstall script, get “uninstall complete” message from terminal, Anki icon disappears from my dock and then I run the 2.1.44 script, yet the version is still 2.1.40! and I still get “Do you want to update” window at startup!

Using Manjaro Gnome.
Version ⁨2.1.40 (cf446733)⁩
Python 3.9.4 Qt 5.15.2 PyQt 5.15.4

Maybe you have older files lying around in another location?

Holy shit, I love you @dae wouldn’t have survived the last few academic years, maybe would’ve straight up dropped out, if it wasn’t for Anki.

Ok so, I searched via root folder and deleted all the files with keyword Anki. I did find a binary “Anki” in /proc/63105/cwd/bin/ and a symlink (I think its called) to downloads folder 's Anki dir inside cwd/bin .

I figured it was time for a long awaited distro hop and wiped my root partition, installed Manajaro KDE, and still 2.1.40 greets me! I don’t know how that’s possible since anki is always installed with sudo and I always use tar package from the website.

The proc entries are likely your terminal. After uninstalling Anki, what happens if you type in ‘anki’ or ‘Anki’ in the terminal?

I distro hopped to ubuntu in the meantime and the update problem is gone.

I tried to replicate it by uninstalling current version and installing 2.1.40 again but it seems fine in ubuntu, will report back if its still present on manjaro.

I did type anki on terminal while on manjaro and the terminal said command not found.