Anki Forums

Windows update broke Anki

Until yesterday, anki was working well, but since i tried to open it today, it just doesn’t open :frowning: The only thing that happens when i try to open anki is that the load sign appears for a second and then it disappear, nothing else, even an error message also doesn’t appear. The first thing i tried to do was to restart the computer, but the problem persisted. Then i tried to uninstall Anki, download the latest version and restart the computer, but the problem persisted. Then i googled it and tried things like trying to open while holding shift key, open as administrator and right-click the icon and select to run with graphics processor NVIDIA. None of this worked. Then i came here and followed instructions i found here on the support and i checked Windows Update and downloaded and installed all updates and restarted the computer, but the problem persisted. Then i tried to open “cmd.exe” and type “cd \program files\anki anki-console” as instructed, but the window says that the system can’t find the path specified.

I don’t know more what to do. Please someone help me.

9 Likes

can you downgrade to an older version to see if that solves the problem?

someone else having the same problem

Hello mmdj2, thank you very much for your answer. I did as you said right now, but unfortunately it didn’t work :frowning:

I am also having the same problem since yesterday afternoon - when clicking on the Anki icon to open, the program appears quickly in the Windows Task Manager and nothing else happens, the program is not opened.

In addition to the aforementioned attempts, I tried the instructions contained in https://faqs.ankiweb.net/when-anki-does-not-start-on-windows-debugging-steps.html, where it indicates to execute a command in cmd, however, it also didn’t work.

I hope someone can help us as soon as possible.

PS. this text was written in BR Portuguese and then translated into English.

Estou com mesmo problema.
Instalei a versão anterior. Reiniciei computador e não resolveu.

Consigo abrir na opção anki-console. Quando fica aberta a seguinte tela
[7192] LOADER: Running runanki.py
mpv too old for key rebinding
Not found: ‘favicon.ico’

The cd \program files\anki anki-console command seems mistyped.

Try cd \program files\anki & anki-console

Had the same problem. After initiating anki-console.exe, found in the installation path, I tried to open Anki again and it worked. Weird that so many people are having the same problem at the same time.

1 Like

ANH25, Woow! I typed as you said and i was able to open Anki while the cmd was still opened!! But the Anki closes when i close the cmd, do you know how to keep Anki opened without cmd opened too?

Aqui eu tentei abrir com o anki-console aberto, mas não consegui :frowning: Provavelmente meu problema é outro, mas obrigado pela contribuição, amigo. Tomara que ajude outra pessoa que também tá precisando :slight_smile:

Apparently you and JOcab are with similar problem, because he also managed to open with anki-console, unfortunately i couldn’t open with anki-console, so my problem probably is different. But thank you for the contribution, i hope it helps someone. :slight_smile:

Just to be sure, do you usually run Anki from a shortcut?
Could you try running anki.exe in Anki folder (C:\Program Files\Anki)?

Yes, i usually run from a shurtcut, but i already tried to open in Anki folder and it didn’t work :frowning: Doesn’t work through shortcut and doesn’t work through Anki folder. So far the only way i can open it is through the command that you taught how to type.

My Anki won’t open. I already installed the windows upgrades and uninstalled Anki and it didn’t work. It happened today. Yesterday was normal

I have the same problem, Idk what should I do

I have the same problem too! I tried to uninstall and install again four times but it’s not working… it started today, yesterday I used it without problems

Can you run the following commands and post the contents of the anki-debug.txt file that will get created on your Desktop?

cd \program files\anki
anki-console > "%USERPROFILE%\Desktop\anki-debug.txt" 2>&1

(I suggest trying the same to others who face this problem)

The content is this:

[16628] PyInstaller Bootloader 3.x
[16628] LOADER: executable is C:\Program Files\Anki\anki-console.exe
[16628] LOADER: homepath is C:\Program Files\Anki
[16628] LOADER: _MEIPASS2 is NULL
[16628] LOADER: archivename is C:\Program Files\Anki\anki-console.exe
[16628] LOADER: C:\Program Files\Anki\anki-console.exe contains a digital signature
[16628] LOADER: No need to extract files to run; setting extractionpath to homepath
[16628] LOADER: SetDllDirectory(C:\Program Files\Anki)
[16628] LOADER: Already in the child - running user’s code.
[16628] LOADER: Python library: C:\Program Files\Anki\python38.dll
[16628] LOADER: Loaded functions from Python library.
[16628] LOADER: Manipulating environment (sys.path, sys.prefix)
[16628] LOADER: sys.prefix is C:\Program Files\Anki
[16628] LOADER: Pre-init sys.path is C:\Program Files\Anki\base_library.zip;C:\Program Files\Anki
[16628] LOADER: Setting runtime options
[16628] LOADER: Initializing python
[16628] LOADER: Overriding Python’s sys.path
[16628] LOADER: Post-init sys.path is C:\Program Files\Anki\base_library.zip;C:\Program Files\Anki
[16628] LOADER: Setting sys.argv
[16628] LOADER: setting sys._MEIPASS
[16628] LOADER: importing modules from CArchive
[16628] LOADER: extracted struct
[16628] LOADER: callfunction returned…
[16628] LOADER: extracted pyimod01_os_path
[16628] LOADER: callfunction returned…
[16628] LOADER: extracted pyimod02_archive
[16628] LOADER: callfunction returned…
[16628] LOADER: extracted pyimod03_importers
[16628] LOADER: callfunction returned…
[16628] LOADER: Installing PYZ archive with Python modules.
[16628] LOADER: PYZ archive: PYZ-00.pyz
[16628] LOADER: Running pyiboot01_bootstrap.py
[16628] LOADER: Running pyi_rth_multiprocessing.py
[16628] LOADER: Running pyi_rth_win32comgenpy.py
[16628] LOADER: Running pyi_rth_pyqt5.py
[16628] LOADER: Running pyi_rth_certifi.py
[16628] LOADER: Running pyi_rth_pkgres.py
[16628] LOADER: Running pyi_rth_pyqt5webengine.py
[16628] LOADER: Running runanki.py

This is identical to the output I get, though I have no problem running Anki 2.1.29

Have you tried opening mplayer.exe ?

Tried now, didn’t work too :frowning: