Anki Forums

Cannot open Anki desktop after upgrading to 10.13.4

Two problems really: I bought a new MacBook Pro (OS Catalina 10.15.5) and the software on my 2011 MacBook was transferred to it. The old laptop couldn’t be upgraded with the latest version of Anki so the older version was transferred to it. Today, I tried to add cards on the new machine (up till now I’ve been using the old one) and it wouldn’t let me do that. I couldn’t even open the ‘add’ screen. So I thought it must be that the new machine isn’t compatible with the old software. But I couldn’t close the old version, and having done the upgrade I can’t open the new version. The icon at the bottom of the screen bounces uyp and down but absolutely nothing happens - no dialogue box, nothing. It doesn’t even look as though Anki is open - but when I try to restart my machine, it tells me that Anki has prevented restart - please close Anki. The only way I can do that is ‘force quit’ which I’ve done a couple of times. But nothing is happening. I’ve seen another comment on the forum where a user suggests it is the media player which is interfering, but as far as I can see that isn’t on.
The only other thing that has changed is that I downloaded Office 2019 today (previously 2008 version).
Any advice please? I can go back to adding cards on my old machine, but I want to get this one working as the old one is close to total collapse.

Thanks!

Sorry should have said that I downloaded 2.1.34

Try to start Anki from Terminal app by copy-pasting the following command and pressing Return.

/Applications/Anki.app/Contents/MacOS/Anki

Maybe it’ll print something useful.

Thanks for suggestion. I’ve tried it, but nothing. No reaction.

This is strange. I don’t have Mac, but I thought that it’d print some debug information to the console. At least, this is how it used to work in the past, as far as I know.

I can only suggest to try to install the alternate Anki version from the website.

I installed the alternate version - same problem, sadly. The more I think about it, the more I think the problem started with installation of Word. I’m going to try uninstalling that and see if that changes anything.

I presume you were able to successfully restart the computer before you tried opening Anki again? Do you have an Anki folder in your Documents folder? Do you use iCloud drive?

Yes, I’ve restarted a couple of times, without problem - though no difference in response. On checking, I do have an Anki folder in Documents - with one file (prefs.db). I don’t use iCloud drive.

Please try renaming the Documents/Anki folder to something else, renaming the Anki2 folder in Application Support as well, and then start Anki - does it make any difference?

Apologies for my delay in responding: I was moving house. Thanks too for the advice.
I can’t find an Anki folder in Application support at all - and the only file in the Anki folder in Documents is the prefs.db one.

I tried renaming the Anki folder in documents and it didn’t make a difference.

Please open Terminal.app and run Anki from the terminal with the following command:

/Applications/Anki.app/Contents/MacOS/Anki

Please copy and paste the resulting text you see - perhaps it will give a clue as to what’s going on.