Can't properly install Mac OS X 10.13.4+ (2.1.35-standard)

Hi everyone,
I have a macOS Catalina version 10.15.7 and can neither install/make the
new update Mac OS X 10.13.4+ (2.1.35-standard)
nor the alternative Mac OS X 10.10+ (2.1.35-alternate) work.

Everytime I try to open Anki I get the following error message:

When I click on ok, this window opens:

When I then try to Downgrade & Quit, I get this message:

During this whole process, I cannot see the Anki menu bar i.e., switching to a different user profile like some people have suggested on Reddit is not an option.
I have also tried to open a backup but I only briefly see an Anki menu with 0 cards and then the same sequence of error messages I mentioned above pops up.

Finally, I have tried to completely deinstall Anki from my Mac and reinstall the new version but that hasn’t helped either. My decks are synchronized to AnkiWeb, so I should be able to download them back into a new desktop version of Anki. Any ideas on how I can fix this problem would be highly appreciated.

Thank you so much,

You’re probably accidentally opening an older version of Anki you have lying around - please make sure you’re opening the .35 version you downloaded.

You probably hear this all the time but I swear I tried this at least a dozen times before and it only worked just now. Thanks! :raised_hands: