Cannot launch Anki app due to Add Ons bug - help needed & appreciated

Hi guys,

I appreciate any help that can be offered. I am new to Anki so apologies if this is a rookie problem.

I cannot launch the Anki app on my MacBook. There appears to be a bug related to add ons (I downloaded the add ons recommended by Anking). However, because I cannot enter the Anki interface, I am unable to delete the problematic add on.

I believe the problematic add on is: Image Occlusion Enhanced for Anki 21 alpha

I have pasted the main error message below.

I appreciate any help - Thanks very much!

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.

If the issue only occurs when add-ons are enabled, please use the Tools>Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.

When you’ve discovered the add-on that is causing the problem, please report the issue on the add-ons section of our support site.

Debug info:

Anki 2.1.15 (442df9d6) Python 3.6.7 Qt 5.12.1 PyQt 5.11.3

Platform: Mac 10.15.5

Flags: frz=True ao=True sv=?

Add-ons possibly involved: Image Occlusion Enhanced for Anki 21 alpha

Caught exception:

File “aqt/”, line 279, in accept

File “aqt/”, line 234, in doOpen

File “aqt/”, line 253, in _openBackup

File “aqt/”, line 186, in onOpenProfile

File “aqt/”, line 276, in loadProfile

File “anki/”, line 29, in runHook

File “/Users/lachietalbot/Library/Application Support/Anki2/addons21/1374772155/”, line 203, in onProfileLoaded


File “/Users/lachietalbot/Library/Application Support/Anki2/addons21/1374772155/”, line 78, in getSyncedConfig

if ‘imgocc’ not in mw.col.conf:

<class ‘AttributeError’>: ‘NoneType’ object has no attribute ‘conf’


Launch Anki while holding the shift key to disable add-ons (as stated in the error message).
The issue seems to be caused by the Image Occlusion Enhanced for Anki 2.1 add-on as you guessed.

Thanks very much ANH25,

I have tried to launch Anki with the shift key and I still could not get into the Anki interface (see attached screenshot).

As soon as I enter Anki, I get the pop up message:

“Anki was unable to open your collection file. If problems persist after restarting your computer please use the Open Backup button in the file manager”

If I click OK it just sends me back to my profile selection screen. So I can’t actually get INTO Anki. I have restarted my computer and nothing seems to change.

Thanks again for anyone who has any ideas! And I appreciate the help.

This seems to be another issue with your collection.
If restoring a backup didn’t help, I’m not sure if this can be solved.

Thanks ANH25,

I am very new to Anki, but I did have a feeling that the system was running a bit ‘slow and clunky.’ Some of my med school buddies uploaded several large decks to my Anki account, including Anking and Dope Anatomy, and I thought there may have been some intrinsic problem (i.e. overload).

In the case that restoring a back up does not work, is the best thing to do to uninstall the whole Anki program and then start from scratch?

And from that point onwards be more selective about what I upload?

Thanks again.


Since you’re new to Anki and don’t have much to lose in your collection, I suggest starting from scratch by adding a new profile from the profiles screen and deleting the old one (you seem to have two profiles already).

Thanks very much!

Much appreciated :slight_smile:

Regarding the error message, please see the note at the top of