Can’t synch media with iPhone anki

I get errors when I try to synch. I tried uninstalling and reinstalling the app.

You appear to have a few files in your AnkiWeb account with invalid filenames. If you update to the latest computer version, run Tools>Check Database, then sync, does that resolve the issue?

I tried updating my desktop Anki and resynching and that hasn’t fixed the issue.

Paul Walther

5755 e River rd APT 2105

Tucson, AZ, 85750


I’ll need to write a little tool to fix this - I should hopefully have a fix for you later today.

So, this is a bit more complicated than I expected - the characters are not readable, but they are valid utf8, and when I tried one of them, I don’t get the illegal byte sequence error. Would you mind sending me your media log in a private message or on the other support site? You can get it by tapping on debug at the top right of that screen.

I couldn’t figure out how to send a private message so here’s a Dropbox link.

[link removed]

I made a change to a deck and had to upload to ankiweb and I got this message:


I’ve never seen it before. I don’t think I’m having any network issues.

Ok, so the problem is that one of the files has a “valid” utf8 character that has not been assigned yet, and Apple platforms won’t allow it to be used. You should be able to remove the file from your media folder in the computer version manually and then sync to fix the problem. The name is

�׸�1.png and it’s 543339 bytes.

The timeout issue is a bug in 2.1.31, and has been fixed in the 2.1.32 release.

1 Like

That was bizarre. I couldn’t see the characters you wrote but copy and pasting it into Anki worked and I was able to find the image and remove it. It works fine now. Thanks for your help.