Can`t open anki after download

Hey there,
I have a problem with the desktop version of anki. I downloaded the Silicon-Anki as recommended for Macbook M1 users. After dragging anki to the applications folder and opening it I will get an error with the note anki got closed unexpectedly. No matter how many times I try it won`t even open. Does someone know how to fix it?

Thanks for help!

See 2. check add-ons

Try latest pre-release Qt 6

most add-on will break because they haven’t been ported to 23.10 yet, if you require the add-ons you use, stay on 2.1.66 for the time being

Thank you!
I checked the add-ons and even when I press the shift button while opening anki or deactivating the add-ons the problem still remains. I also tried to restart the app and the macbook. Same problem. I tried the latest pre-release and the same error message comes up.

Is there error logs? when the error message pop up, should be “show logs” or similar

Hi! I am having the same issue - all I see is “Anki quit unexpectedly” and then the options “Reopen”, “Report…”, or “Ignore”.

Please click on Report, then paste the first ~100 lines here.

Process: anki [18031]
Path: /Applications/Anki.app/Contents/MacOS/anki
Identifier: net.ankiweb.dtop
Version: ???
Code Type: X86-64 (Translated)
Parent Process: ??? [1]
Responsible: anki [18031]
User ID: 501

Date/Time: 2023-11-10 11:18:37.649 -0500
OS Version: macOS 11.6 (20G165)
Report Version: 12
Anonymous UUID: D44AB4F4-339E-7709-E566-C2948ADC6CEB

Sleep/Wake UUID: 51821EFA-6C07-4640-834D-24F7C5301BD8

Time Awake Since Boot: 24000 seconds
Time Since Wake: 85 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000004419000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [18031]

VM Regions Near 0x4419000:

__TEXT 104419000-106b39000 [ 39.1M] r-x/r-x SM=COW

Application Specific Information:
dyld: launch, running initializers

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 0x0000000104538f67 malloc_conf_init_helper + 279
1 0x00000001080cca44 ???
2 0x000000010453891f malloc_init_hard_a0_locked + 127
3 0x000000010453c32f malloc_init_hard + 159
4 dyld 0x00000002070c1b47 ImageLoaderMachO::doModInitFunctions(ImageLoader::LinkContext const&) + 535
5 dyld 0x00000002070c1f52 ImageLoaderMachO::doInitialization(ImageLoader::LinkContext const&) + 40
6 dyld 0x00000002070bcae6 ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, char const*, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 492
7 dyld 0x00000002070ba89f ImageLoader::processInitializers(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 191
8 dyld 0x00000002070ba940 ImageLoader::runInitializers(ImageLoader::LinkContext const&, ImageLoader::InitializerTimingList&) + 82
9 dyld 0x00000002070a68b1 dyld::initializeMainExecutable() + 199
10 dyld 0x00000002070ad041 dyld::_main(macho_header const*, unsigned long, int, char const**, char const**, char const**, unsigned long*) + 9098
11 dyld 0x00000002070a5224 dyldbootstrap::start(dyld3::MachOLoaded const*, int, char const**, dyld3::MachOLoaded const*, unsigned long*) + 450
12 dyld 0x00000002070a5025 _dyld_start + 37

Please download 23.10.1 and it should fix the problem.

Downloaded that, still having the same issue

If you right click on the anki app and select “Get info”, does it say version 23.10.1, like here?

Yes, it is the same version 23.10.1 but I use the mac version instead of intel like it was recommended for M1/M2 Macbooks. And still the same error message.

This crash was fixed on older intel macs, but seems like it persists on apple silicon macs. Unless a patch is released that fixes it my suggestion would be to upgrade to the newest macOS, since the crash probably is due to your old os.

1 Like

I have tried downloading Anki a few times and it has never worked. Each time it comes up with the same error message saying it quit unexpectedly.

See other thread:

I will see if anything can be done about this; in the mean time if you use the -intel version of Anki instead of the -apple version, it should work.