"Anki quit unexpectedly"-error when trying to open Anki

System: iMac Mid 2010, MacOS High Sierra 10.13.6
Anki version: Intel, 23.10 Qt5

I tried to update to the latest Anki version today and am facing an issue now.
Every time I try to open Anki, I get an error that says “Akni quit unexpectedly” and the app closes itself immediately.

Steps tried:
Uninstalled and reinstalled
Press shift while opening Anki
Restarted computer.

Nothing helped unfortunately.

Crash log below.

Process:               anki [71107]
Path:                  /Applications/Anki.app/Contents/MacOS/anki
Identifier:            net.ankiweb.dtop
Version:               23.10 (0)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           anki [71107]
User ID:               501

Date/Time:             2023-11-06 15:47:34.888 +0100
OS Version:            Mac OS X 10.13.6 (17G14042)
Report Version:        12
Anonymous UUID:        36029B77-ACF1-38B6-DCF9-613B9D491F17

Sleep/Wake UUID:       AEAB77A5-DC20-4C6A-95A6-EA7FD4CA47A3

Time Awake Since Boot: 3000000 seconds
Time Since Wake:       28000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x00000000007c4000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

VM Regions Near 0x7c4000:
    __TEXT                 00000001007c4000-0000000102ee4000 [ 39.1M] r-x/r-x SM=COW  /Applications/Anki.app/Contents/MacOS/anki

Application Specific Information:

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   net.ankiweb.dtop              	0x00000001008e3f67 malloc_conf_init_helper + 279
1   net.ankiweb.dtop              	0x00000001008e391f malloc_init_hard_a0_locked + 127
2   net.ankiweb.dtop              	0x00000001008e732f malloc_init_hard + 159
3   dyld                          	0x000000010b969ac6 ImageLoaderMachO::doModInitFunctions(ImageLoader::LinkContext const&) + 420
4   dyld                          	0x000000010b969cf6 ImageLoaderMachO::doInitialization(ImageLoader::LinkContext const&) + 40
5   dyld                          	0x000000010b965218 ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, char const*, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 330
6   dyld                          	0x000000010b96434e ImageLoader::processInitializers(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 134
7   dyld                          	0x000000010b9643e2 ImageLoader::runInitializers(ImageLoader::LinkContext const&, ImageLoader::InitializerTimingList&) + 74
8   dyld                          	0x000000010b955567 dyld::initializeMainExecutable() + 196
9   dyld                          	0x000000010b95a239 dyld::_main(macho_header const*, unsigned long, int, char const**, char const**, char const**, unsigned long*) + 7242
10  dyld                          	0x000000010b9543d4 dyldbootstrap::start(macho_header const*, int, char const**, long, macho_header const*, unsigned long*) + 453
11  dyld                          	0x000000010b9541d2 _dyld_start + 54

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x00000000007c4000  rbx: 0x0000000102e4ba98  rcx: 0x00000001008e6ae0  rdx: 0x0000000000000001
  rdi: 0x0000000000000000  rsi: 0x0000000000000000  rbp: 0x00007ffeef436970  rsp: 0x00007ffeef4368d0
   r8: 0x00007ffeef4383c0   r9: 0x000000000000003f  r10: 0x00007ffeef43bce8  r11: 0x00007fff57811f40
  r12: 0x00000001008e6af4  r13: 0x0000000000000001  r14: 0x00007ffeef4383c0  r15: 0x00007ffeef4387d0
  rip: 0x00000001008e3f67  rfl: 0x0000000000010207  cr2: 0x00000000007c4000
Logical CPU:     2
Error Code:      0x00000004
Trap Number:     14

Try this instead.

1 Like

Thank you very much, this version is working :+1:

It’s painfully slow though.

I think I will stick with version 2.1.66 for now.

There is a chance that changing video drivers (Preferences → Appearance) could fix the slow down, if you want to upgrade you could try that. Did you try the Qt5 or Qt6 version?

1 Like

Thanks for the tip!

I tried changing the video drivers on the Qt5-Version (because my Imac is too old for the Qt6-version) and it didn’t help unfortunately.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.