Bug: Updated to 2.1.54 and "E" to edit shortcut no longer works

Hi, long time user of Anki, first time forum poster. I use Anki primarily to reinforce learned foreign language vocabulary.

I recently updated to 2.1.54 Qt6 on my work computer, and now pressing “e” on the keyboard while reviewing a card doesn’t properly open the “edit” function. More specifically, it seems to work when my keyboard is set to English, but as I’m almost exclusively using typing prompts in Korean (using Microsoft IME), my keyboard is rarely set to English while reviewing. In the version I was using previously, “e” opened “Edit Current” properly even while using the Korean keyboard.

For now I’m holding off on updating Anki on my home machine, which I do use more, but it would be nice if this could get fixed somehow? Again, my home machine is running a slightly older version and the “e” shortcut still works fine even when they keyboard isn’t set to English. For reference both computers are running Windows 10. My home machine does include a lot of add-ons, but my work computer doesn’t have any add-ons at all on Anki, so that shouldn’t be a factor, either.

Also, I’m sorry if the forums aren’t the right place for this; I was searching but couldn’t seem to find a place for bug reports. If there is one, could you let me know? Thanks.

2 Likes

There is a place dedicated to report bugs (the issue tracker on github), but posting on this forum is fine, especially if you are not tech-savvy.

Is it a problem with the -qt5 version of 2.1.54?

The quoted post is about Anki 2.1.52 qt6, but I am still experiencing the same issue in 2.1.54 qt6.3.1

If you install the latest version of Anki with Qt6 (issue does not reproduce on Qt5) cards that prompt input via {{type:Back}} have a focus issue when using a Japanese IME. This may appear on other IMEs but I did not test them. If the card has the type token on both front and back template, the front card should accept input, and the back card should display the answer + delta.

However if you input using an IME (I’m using Microsoft IME) Anki is not properly focused on the back card to allow use of the keyboard to select card ease levels Again, Hard, Good, Easy with input 1,2,3, and 4 respectively. Instead, an IME prompt appears requesting further selection indicating its typing into some hidden text field. To properly input an ease level, you must additionally press TAB in the IME window then your desired input, or use the mouse/keyboard to refocus the Anki window.

This issue does not appear on Qt5, as the Anki window is properly focused after typing an answer + hitting return.

1 Like

Sorry for not including images in the original post. Seems like Firefox doesn’t like uploading and I had to switch browsers :slight_smile:

1 Like

@language_learner I merged these topics, but they may be two similar but distinct issues. Are you also using type-in-the-answer cards? If you hit tab like the other poster, does that allow E to work?

I am also using type-in-the-answer cards. I believe they might be the same issue, though I’m not sure, but because of the differences between Japanese input and Korean input, I don’t experience the same issue with the 1/2/3/4 shortcut keys at all. I’ve used Japanese IMEs before; because of the way typed Japanese has to be converted into different possible kanji (Chinese characters) or other formats, it often defaults to these types of “choose between options” menu as shown above, even for numbers, whereas Korean is normally just typed in the actual alphabet unless you’re specifically converting to Chinese characters. Both seem like focus problems, it’s just that it looks like for Japanese that affects both numbers and letters whereas with Korean it only affects letters, so number shortcuts work fine but alphabet shortcuts don’t. The tab thing is unique to the Japanese IME though.

I’m not sure it’s exclusively an issue on the back of the card though; I also used to be able to use keyboard shortcuts like “e” on the front of the card so long as I clicked outside the textbox so I was no longer typing in that, and that didn’t work anymore either.

But it does seem to be only a problem for Qt6, I ended up switching to Qt5 on my work computer and that works just like it always did, no issue.

You may use ‘Ctrl+Shift+E’ shortcut
I’ve got the same problem with Russian keyboard, so I either have to switch on English one or to use Ctrl+Shift+E.

I’ve added this to Investigate shortcut issues in review screen in Qt 6.3 · Issue #1952 · ankitects/anki · GitHub

Joined to report exactly this issue, typed it all out, then found this thread at the last minute with basically everything I wanted to say. :sweat_smile:

Only have 2 things to add.
1: I’ve tested both 2.1.49 (no bug present) & 2.1.50 Qt6 (bug is present). I wasn’t able to test Qt5 (doesn’t work on my machine), but based on Riyu’s report, it seems like the bug was introduced only when the Qt5 & Qt6 split happened in version 2.1.50.
2: For me, tabbing out & back in refocuses the window & re-enables hotkeys. idk what could possibly be in Qt6 that makes this bug worth suffering, but that’s another method of working around it if Qt6 is really necessary for you.