Bug? Random note doesn’t pull both front & back

I am using “new card gather order” set to “random notes”, and burying is disabled. All my notes are for front/back cards. But, if I add 2 new cards to my daily limit, they are not a front back pair. This seems like a bug. How can I resolve this? Currently I must manually set the due date of the back to ensure I study both…. Not sustainable.

Thanks for any help!

iPhone, Anki Mobile 23.12.1

Some possible explanations:

  • you have burying enabled in the deck options of a subdeck
  • you have more than one note with the same due # in the browse screen, which can happen if you make changes on multiple devices and forget to sync when moving between devices.
  • the reverse cards were added later (e.g. by changing from ‘basic’ to ‘basic (and reversed)’)

Thanks for your fast reply. It’s definitely not the first two, but it could be the third. If it is, how would I fix it?

You can check this by looking at the Due date in the browse screen. Do the forward and reverse cards have the same due #? If so, they should appear on the same day with your chosen gather order, assuming neither gets buried.

This problem is about drawing new cards, which don’t have due dates yet. It used to be the case that, if I scheduled 14 new cards each day, I would get the front and backs of 7 notes. But that’s not happening.

If you look at the “Due” column, Review cards have a date, but New cards have a “New #” that says where they are in the queue. Usually, sibling cards (the front and back cards you’re talking about) will have the same “New #” – but if they are created at different times, or if the queue ordering is changed, they might not.

Ex. These 5 cards are siblings. Cards 1 and 2 were created together. Card 3, then card 4, then card 5 were created later by additional templates being added. (Then I manually set card 5 to match the queue number of 1 and 2.)

To check this in your collection, sort by the “Due” column, and make sure that siblings are showing up together in pairs.

If that checks out, is it possible that you’re just 1 card off and seeing the reverse card of #10, followed by the front of card of #11?

[As an aside]

If you’re using “Set Due Date” – that is also converting those cards to Review cards, and skipping the learning steps. Probably not what you intend. Browsing - Anki Manual

Yes, I would like to stop setting the due date so I don’t skip the learning steps. That’s my only solution right now. My cards all seem to be paired. Here is a screen shot

I included the text so you can see that the card content is repeated. The two cards in the middle two rows are cards whose siblings have already been reviewed and assigned due dates. Still, I don’t think this should throw off the new-card drawing algorithm. Any ideas? I’m really concerned about getting this working properly again.

This is definitely solvable – we just have to find the right path.

Next thing to check is your Deck Options for this particular subdeck and every deck above it in its tree – especially including any other decks you click on to study. I know, I know, you’re very sure it’s not that. But I’m asking you to check again to humor me.

I only have one deck options preset, so all decks are the same. I confirmed that I only have burying enabled for review siblings, not new siblings. I double checked all decks, and now I can’t reproduce the problem. There must be a problem because I have a lot of these stray cards that never had the “back” sibling reviewed. I will continue to try to reproduce this, and follow-up here.

What happens if I schedule (say) 6 new cards in a day, but only start learning 3 of them? On the next day, to pull only 6 cards, would Anki to pull 3 cards that are only fronts? (because I sort by card type)?

Also, what happens when I add new notes? I pull “sequential, oldest first” so those shouldn’t get inserted before and un-studied “backs”, right?

Since you use a Gather Order of “Random notes” (Deck Options - Anki Manual) – the next day Anki will choose a random note, and gather all of its cards, until that note is out of cards or the gather limit is reached. Then it will move on to another random note and do the same thing. There’s no guarantee that these will be the same notes you started learning cards from yesterday, or that they will include any of the notes that have only a Card 2 left.

Then after they have been gathered, Anki will sort those 6 cards by card type and show you all of the Card 1s before the Card 2s. Deck Options - Anki Manual

If this is what you’ve been doing, that entirely explains why you have these stray Card 2s!

“Sequential, oldest first” isn’t a pull/gather order, it’s your insertion order (Deck Options - Anki Manual). So yes, new notes will create cards at the “end” of the “New #” queue. But since you aren’t gathering new cards in that order, it won’t matter.

So, I think your solution here is change your settings to match what you actually want to have happen. Is this about what you’re looking for?

  1. Among your current notes, you don’t care what order you introduce them in, but you want to learn each note’s Card 1 and Card 2 on the same day.
  2. For new notes that you create, you want their cards to get in line behind all of your current New cards. [And is there a subset of current cards that have been recently created that you want to keep at the end of the queue too?]
  3. Right now, you want to locate all of the stray Card 2s and get them introduced as soon as possible.
1 Like

Yes, the goals you enumerated are what I am trying to achieve. I assumed that my new cards list is a stable queue that doesn’t wholly change day to day, but is rather is appended to. What should I do? I think I need to disable sorting by card type so that the front/back pairs are interlaced together in the new list (all backs immediately follow fronts so I can ensure they get pulled into the learning steps together).

If introducing the forward and reverse cards on the same day is important to you, you’ll either need to change the sort order so they’re shown one after another (which will reduce the chances of the siblings being left if you stop part-way through, but will mean you’ll see the same content twice, making it much easier to answer the second card), or change the gather order to a non-random option, so that things pick off where they left off when sessions are terminated part-way through.

That’s mostly correct – or at least, it can be – but you chose Options that disregard that list.

To make the above goals happen, I’d suggest the following Options instead (top to bottom) –

  • New Insertion Order – Sequential (oldest cards first). This is to make goal #2 happen.
  • New Gather Order – Ascending position, or if you have multiple decks and it matters to you, Deck. This determines which new cards will be introduced each day – they will come in the order of their "New #"s. Since you have new-burying turned off, this will cause Anki to “pull” the sibling cards as a pair (once everything evens out), as per goal #1.
    • If those New #s already have the cards in some weird order (like alphabetical, or parts of speech), and you want them to be more “shuffled” than that (or in some other particular order), just speak up, because there are solutions to that too.
  • New Sort Order – Once your 6 cards (or however many) are chosen for the day, this determines how you’ll see them. You can really pick anything you like here – Deck Options - Anki Manual – but I would endorse Card type, then random for you. You’ve already decided to introduce siblings in the same day, so I won’t try to talk you out of that, but this will at least show you all of your Card 1s in some order, followed by all of your Card 2s in a different order.

To make goal #3 happen, this might sound a little complicated, but this is how I’ve done it before, and it works!

  • Find all Card 1s that are in review, card:1 -is:new, select all, and “Toggle Mark” those notes. Browsing - Anki Manual
  • Now search within the marked notes to find all Card 2s that are still new tag:marked card:2 -is:suspended is:new. These are those stray Card 2s. Select all, “Reposition” those to a “start position” of 1 (or whatever low number), Browsing - Anki Manual. This pushes them to the front of the line, so they’ll be the next ones introduced.
  • Clean-up by un-marking those notes – tag:marked, select all, “Toggle Mark”

After however many days it takes to introduce all the stray Card 2s, you might find that your 6 daily new cards are “off” by 1 (i.e. Anki is picking 2,1,2,1,2,1, instead of 1,2,1,2,1,2). If you want to get that aligned again, you can set a today-only new card limit of 5 or 7 for one day, Deck Options - Anki Manual. But you can also just leave it, because you won’t lose those stray Card 2s anymore, they’ll just be introduced the following day.

1 Like

I cannot thank you enough! I would have never figured this out, and it was a real mess. I had 81 stray cards. I took it one step further, and repositioned all non-stray new cards starting at number 82, so I will immediately review all the strays before starting to learn brand new words. This exercise taught me how to use the desktop app’s browser better, and I verified that the new ordering therein matches the order in which the new cards are being drawn in the iPhone app.

For the “new card sort order,” I have been using “card type, then random,” but it seems wiser for me to use “order gathered” because I don’t always finish my cards every day. If I keep them in “order gathered” the front/back siblings will be interlaced so I can ensure I always start both siblings in the learning steps together. I then use burying for review cards to prevent them from being shown together in subsequent days. Sure, the siblings collide on the first day, but I find it helpful to learn them together nonetheless. I have found it too difficult to wait a day to start learning the “back” siblings. Please let me know if you have alternative suggestions. I’d be curious to learn about other strategies.

1 Like

Yes, that sounds like a better fit for how you are studying than my suggestion. I’m glad you found that!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.