[Bug] Anki 2.1.52 crashes after adding new Note Type

OS: Manjaro KDE (latest stable) - X11
Anki QT6 Version 2.1.52 (WITHOUT add-ons)

Description: Anki 2.1.52 crashes after adding new Note Type. I cannot add any “New Note Type” because anki crashes and the whole PC becomes unresponsive.

I tried to add “Basic” cards, Cloze, etc and the bug is always present.

@dae you can try to reproduce downloading the whole deck from my account:

My deck can be shared publicly to allow others to reproduce.

Have you tried setting the driver option to “software” instead of “OpenGL”?


I believe that the bug in Anki might be caused by the content of my Deck.* It happened once a few months ago (Beta 2.1.50).

I will try these and write again:

@dae the bug happens setting the driver to “OpenGL” and also with “software”.

My internet is too slow as to update the deck (500 MiB) to a cloud service.

I hope it would be possible to download the deck to reproduce the bug:

What makes you believe so? Are you unable to reproduce this issue with an other deck?

What makes you believe so?

During 2.1.50 beta I reported a bug that lead to a commit by Henrik Giesel and was related to the HTML content of cards.

Are you unable to reproduce this issue with an other deck?

I tried with another user profile and a different deck and the issue can be reproduced.

Adding any kind of “New” Note Type crashes Anki and the PC becomes unresponsive…

I’m not able to reproduce this issue, even when using your collection. I tried both via the add screen>type>manage, and via the main window>tools>manage notetypes. You could try resetting your preferences by renaming prefs21.db while Anki is closed to see if that makes any difference: Managing Files - Anki Manual

I renamed “prefs21.db” to reset all my preferences. Unfortunately, the bug is still present.

After all, it might have no relation with my deck. The problem was not present in Anki 2.1.51. Seems a regression.

Let’s keep this thread open in case a developer can reproduce the issue and provide more valuable info. Thanks !

I am having the same problem with Anki 2.1.53 under Arch Linux (installed via the anki-bin package from the AUR). Trying to create a new note type via
Tools → Manage Note Types → Add → Selecting a note type > Pressing “OK”
freezes the screen. Non-graphical aspects of the system (like audio) don’t seem to be affected. Killing the python process that runs anki unfreezes the screen.

For test purposes, I renamed my Anki directory (~/.local/share/Anki2) and started Anki with a fresh profile. But the problem still occured.

I also have the problem with Anki 2.5.53 on Manjaro. The latest commit by @dae solved some crashes, but this one is tricky !

@cionx if you are a developer, could you please kindly offer some technical details to @dae ?

Does downloading the Anki binaries directly from the website and running those solves the issue?

I always use the binaries directly from the website and the issue happens.

The AUR package is not the culprit. Actually, I have never used it…

That’s quite a shame, Arch is the only Linux distribution (AFAIK) that packages Anki properly (ie. that has a real anki package, not only a anki-bin)!

Are you running plasma on X11 too?

1 Like

Yes, I’m also using plasma on X11, and the problem also occurs with the binaries from the website (both the qt5 version and qt6 version).

However, when I switch to fluxbox for test purposes, the problem disappears. So I guess that this is a plasma-related issue.

I think you should report this to KDE.

Please let me know if the next Anki beta does not fix it.


I just tried the current development version (commit 496bce22 from two days ago) and the problem seems to be gone. Thank you.