Anki Forums

Browser - text pop up when hovering over card [POLL]

This issue started only when updating to 2.1.47. When hovering over a card in the browser, it displays a tooltips like dialog that displays the same text. It is incredibly irritating, does anyone know to disable this?

Screenshot for reference.

2 Likes

@Rumo I presume this is a result of the browser changes in .45 - was this a deliberate change? I can see how it might be useful when the text is truncated due to a narrow column, but it is a bit redundant otherwise.

1 Like

Yes, it was deliberate. I think there was no easy way to discern cells with ellided text. But I’ll check again.

Looks like we would need to subclass QTableView and install an event filter. I don’t think it’s worth the additional complexity because the tooltip isn’t really a problem for unellided text. What do you reckon?

Sorry, I wasn’t advocating for a solution that changes behaviour based on if the text is elided or not - I was just saying that it’s only useful when text is elided, so it might be best just to not show a tooltip instead. Is that what you are suggesting, or did you mean something else?

In my opinion, the benefit of being able to read all cells without modifying columns outweighs the slight awkwardness of redundant tooltips. But it’s not a strong opinion.

1 Like

I don’t have a strong opinion either :slight_smile: What does everyone think?

  • I’d like tooltips
  • I don’t want tooltips
  • I don’t mind either way

0 voters

Bumping this to hopefully get some more answers.

1 Like

Since there’s no clear winner here, I’ve added a hidden option to the 2.1.48 release for now. Running the following in the debug console, then reopening the Browse screen should stop the tooltips from appearing.

mw.pm.set_show_browser_table_tooltips(False)