2.1.48 Release Candidate

If no issues are found, the plan is to release this as stable in the next week or so:


People who use Wayland, please let us know if this build works correctly on your system.

Anki starts with Wayland. Different scaling factors between monitors are now super crisp, which is a good argument to go for Wayland. But there are some Qt issues that make it unusable for me at the moment:

  1. Windows don’t have a drop shadow or border:

  2. Already open windows don’t get focused/brought to the foreground on activation. When I click on “Add” or “Browse” this message appears in the console:
    Qt warning: Wayland does not support QWindow::requestActivate()

Ugh. The first issue appears to be related to client side decorators, and I don’t know if it can be addressed without using the system version of Qt. The second issue seems to be an inherent limitation with Wayland. I’ll wait a bit longer to see how other users fare, but it sounds like I’m going to need to switch the default back to x11. In the mean time you can do so by defining QT_QPA_PLATFORM=xcb before starting Anki. Thanks for testing :slight_smile:

1 Like

For some reason, this version is particulary unstable in my system (Windows 10). A lot of error messages compared to 2.1.47.

I’ll try to find some pattern, but the built in TTS seems to be problematic.

What do the error messages say?

Sorry, I didn’t save the previous messages. It’s not always the same message, but nearly all of them are related to sound / built in TTS and apears just after launching Anki for first time.

Here’s, for example, the last one:

After restarting Anki eveything works as expected.
I’ve newer received similar error messages with previous versions. Also, nothing has been changed in my computer for a couple of weeks.

I had the same issue some time ago, but I was using the 2.1.46 or .45 version, don’t quite remember.

rc2 is now available - please let me know how it goes for you, and if you get any further errors, please copy them here :slight_smile:

1 Like

So far so good, I’ll keep an eye, thanks!

This is from today, as usual just after starting Anki for the first time:

Debug info:
Anki 2.1.48 (466d67ca) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Windows 10
Flags: frz=True ao=True sv=3
Add-ons, last update check: 2021-09-18 20:10:10

Caught exception:
Traceback (most recent call last):
File “aqt\taskman.py”, line 101, in _on_closures_pending
File “aqt\taskman.py”, line 71, in
File “aqt\sound.py”, line 289, in
File “aqt\tts.py”, line 573, in _on_done
File “concurrent\futures_base.py”, line 432, in result
File “concurrent\futures_base.py”, line 388, in __get_result
File “concurrent\futures\thread.py”, line 57, in run
File “aqt\sound.py”, line 289, in
File “aqt\tts.py”, line 569, in _play
File “asyncio\runners.py”, line 44, in run
File “asyncio\base_events.py”, line 616, in run_until_complete
File “aqt\tts.py”, line 604, in speakText
FileNotFoundError: [Errno 2] No such file or directory: ‘C:\Users\zzz\AppData\Local\Temp\anki_temp\tts.wav’

After restarting Anki, everything goes fine.

After seeing the problems mentioned by @kleinerpirat, I decided to test RC1 out on my Wayland system.

I’m running Fedora 34 with GNOME 40 on Wayland, and RC1 worked completely fine for me with no issues.

@kleinerpirat, what DE/distro are you running?

A post was split to a new topic: Creating tags from sidebar

Manjaro with Gnome 40.3.0 on Wayland.

Did you start Anki with QT_QPA_PLATFORM=wayland? Without that env variable, RC1 didn’t start on Wayland for me, so I had to set it manually.

To illustrate this, here’s the main window without and with env variable at 200% scaling:

Without env var (blurry, x11 window UI):

When forcing Wayland with the env variable (super crisp, Wayland window UI):

Ah I see, I wasn’t running Anki on Wayland. I had assumed from the changelog that it would be automatic, but I guess it wasn’t.

Having done so, I can say that you are right and that I ran into all the problems that you ran into.

Thanks for the kind explanations. I am not really all that tech-savvy, as you can see.

1 Like

In my eyes you were right to assume this. I had thought the same and I think that was Damien’s intention. I should have mentioned this issue in my first comment.

Thanks for your report! :relaxed::+1:t2:

2.1.48 has been released as stable. Changes since the last rc:

  • Fix an error message that could appear when deleting notes (thanks to Rumo).
  • The card templates screen no longer defaults to filling empty fields when
    opened from the Add screen (thanks to BlueGreenMagick).
  • Added a hidden option to disable tooltips in the browser table.
  • Another change that may fix the issue cqg reported (@cqg please let me know how it goes).

Thanks to everyone for testing. If you encounter any problems with the stable release, please let us know in a new forum post.