Black screen after answering cloze with touch keyboard for handwriting

I answer my cloze deletion cards via a Wacom pen tablet on Microsoft’s touch keyboard for handwriting, and after answering cards with the stylus’s shortcut button (set to “Enter” on the keyboard), if I hover the mouse cursor anywhere other than above the touch keyboard, the answer side of the card goes black, and the only way to get it to display anything is to either scroll with the mouse or pen tablet (if there’s a scroll bar on the right side of the screen) or click and drag with the mouse on the answer side of the card. I could be wrong, but I think it only happens on cards with audio, or at least occurs more frequently on cards with audio. It doesn’t seem to matter if I move the mouse cursor away from the touch keyboard while the audio is playing or after it finishes, the answer side still goes black.

The issue doesn’t seem to happen if I answer with the “Enter” key on the keyboard, because the touch keyboard disappears if I do that, and also typing in the answer with the keyboard works fine, but it’s only when the touch keyboard for handwriting remains active between the question and answer sides of a card does it happen. In case there is a conflict with my markup, I’m including my card formatting as well:

.box {
background: -webkit-linear-gradient(left, #000099 0%, #3399FF 33%, #3399FF 66%, #000099 100%);
border: solid 2px #fff;
box-shadow: 1px 1px 4px 1px #000066;
opacity: 0.94;
border-radius: 8px;
padding: 50px 15px 30px 15px;

.card {
font-family: meiryo;
font-size: 44px;
text-align: center;
color: #fff;
text-shadow: 1px 1px 1px #000066;
background-image: url(‘_blue-sky.jpg’);
background-size: 100%, auto;
background-repeat: no-repeat;
background-position: left top;
margin: 50px 15px;


.cloze {
font-weight: bold;
color: #ff9900;

img {
zoom: 1.5;
image-rendering: smooth;

.kobi {
font-family: meiryo;
font-size: 28px;
color: #FFF;

.notes { font-size: 24px; color: #666; }

code#typeans { font-size: 44px; font-family: meiryo; }
input#typeans { font-size: 44px; text-align: center; border-radius: 8px; max-width: 1000px; padding: 1px 5px; }

.typeGood { font-family: meiryo; font-size: 44px; color: #00FF00; background-color: #009900; text-shadow: 1px 1px 1px #003300; }
.typeBad { font-family: meiryo; font-size: 44px; color: #FF0000; background-color: #990000; text-shadow: 1px 1px 1px #330000; }
.typeMissed {font-family: meiryo; font-size: 44px; color: #666666; background-color: #ccc; }

@font-face { font-family: kobigraph; src: url(‘_kobigraph_slim.ttf’); }

Here are some screenshots of before and after answering a card:

While the video recording doesn’t show the on-screen keyboard or the taskbar, here is a video of the transition to black happening:

You could try the different video driver options in the preferences to see if one of them helps.

You were right. Changing the video driver (from Direct3D to Vulkan) fixed the issue. Thank you so much!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.