Beta 23.09 build 6 - Issue with bury and undo

I just started testing the new iOS 23.09 build 6 on iPhone (iOS 16), and I experienced a couple of manifestations of what I think is the probably the same issue.

First, when during review I tapped “Bury card,” the card did not seem to bury, but remained onscreen. I tapped it a second time with the same result. Returning to the deck screen and reentering the deck for study again showed that the card had been successfully buried (that is, it did not show up again for review).

A little later, I tried to tap undo to undo a response. But the current card remained on the screen. I tapped Undo a few more times. Then I tried to advance to the next card anyway, and I got the error message “not at top of queue.”

Just as with the bury problem, exiting to the Decks screen and going back into the deck for review showed the cards as I expected, that is, the card for which I had attempted to undo the answer was back up for review as I would expect. This leads me to believe that for both bury and undo, they are doing what they are supposed to, but the problem happens when the queue does not advance to the next card following these actions.

For purposes of reproducing the issue, I hope this does not relate to a particular card or deck, because although I told myself not to sync for the sake of your testing, I did it anyway out of sheer muscle memory. The deck I was in was my “Greek” deck (the parent deck). The card I attempted to bury was card ID 1680969693743.

1 Like

Same issues here. The Undo feature will undo it but the undone card remains on the reviewer screen. I have to manually go to home and then hit deck again for it to change.

Thanks for letting me know!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.