Answer shows incorrect error (indicating need for extra space)

Hello, when using the IPhone version of anki (version 2.0.74) an answer is incorrectly displayed as wrong, indicating a space is missing. For example if the answer is ‘la vie’, it displays it as incorrect and suggest an additional space is needed between both words (which is incorrect). I’ve tried turning IPhone off/on with no result. On the PC where I create the cards I use Version 2.1.43 and all works fine. Is it a problem with the IPhone version? Grateful for any help on how to resolve the problem.

Are you using any keyboards on iPhone that produces special kinds of spaces. For example Asian keyboards often produce wider “full-width spaces”, which are bigger than normal spaces, but still count as one character: " " vs " ". The presence of this bigger space instead of the normal space is picked up as wrong by Anki.

1 Like

Thank you for your suggestion. I checked and removed the French keyboard but the problem still shows up. Looking at it more closely it appears that when I type a ‘space’ between two words, e.g. ‘la vie’, it reads the space as a ‘-’ and therefore an error, showing that a ‘space’ is needed. As the problem doesn’t occur on the PC, indeed it could be something to do with the keyboard. I’ll keep messing with it. Thank you.

The issue is that word is actually split into two lines, perhaps because it was imported from somewhere:

Is the issue only with that card, or with others as well? If it’s just the one card, the easiest way to fix it would be to delete that text and type it in again. AnkiMobile should be updated to handle this in the future.

Thank you so much Damien. That worked! All the best, Al