Ankidroid-folder unavailable

Hey everyone!

When I click on the app it says “AnkiDroid-folder unavailable” and then I arrive on the page for advanced settings.

It seems as it has to do with the /storage/emulated/0/Ankidroid folder.

The only folders that I can find is the following:

Haven’t reinstalled or updated it. This just occured out of nowhere.

Is there any way to get by this or is my data lost?

//worried user.

Your data isn’t lost! It’s right there in the picture (although I don’t know if that the most updated version you have on your device). Let’s just figure out a way to get AnkiDroid to see it again.

What version are you using?
Menu > Settings > About > Copy debug info

What directory location is AnkiDroid looking at?
Menu > Advanced > AnkiDroid directory

1 Like

Thanks for you response!

Unfortunately when I go into Ankidroid it immediately takes me to a page with “advanced settings” that I’m unable to go anywhere else from.

However, my phone says it’s version 2.17.6.

And directory location is /storage/emulated/0/Ankidroid as shown in the picture (Ankidroid sökväg).

I don’t know why the automatic storage migration process didn’t trigger for you, but let’s figure out the easiest way to move your data manually.

Before you updated, was your collection in sync with AnkiWeb? If so, you can change your AnkiDroid storage to the new location (see link), and then force a one-way sync to download from AnkiWeb. If not, we can look at other options.

FAQs – Storage Migration FAQ · ankidroid/Anki-Android Wiki · GitHub
Full Storage Access · ankidroid/Anki-Android Wiki · GitHub

1 Like

Nope, I haven’t synced AnkiDroid to AnkiWeb. Everything is stored on my phone!

I think your best bet is to install a “parallel” version of Anki that’s from GitHub instead of the Play store. Those steps are described in #1 of the “Full Storage Access” link above.


Okey, I see. I like it that they don’t offer automatic updates, from what I read. Gives me more control.

Anyway, thanks for you time! :grinning:

1 Like

Hello, im sorry to bother you but i have the exact same problem. I didnt sync my Anki and i have all the Anki data on my Phone (no SD-card). This problem occured yesterday out of a sudden (i dont know of any updates that could have been installed).
If i check the AnkiDroid file i still have all the collection media (All Pictures except for the ones i took with the Anki camera) but the data folder is empty (> com.ichi2.anki > files > AnkiDroid (0 elements)) (unlike in the picture of Anki-Olau, or a friend of mine i have a ‘data’ folder under the folder)

If you say that the data should still be on my phone and maby the PlayStore has something to do with the problem, do you have a suggestion where com.ichi2.anki files could have been moved? Or do you think the data is lost then?

if i check the settings > Apps > AnkiDroid > manage storage place - i could possibly delete 593 MB of App-data but it says error if i wanted to delet the collection, the backups or the ‘not used media data’

In my backup folder i have several backups but they are only 1,71 MB big, so there are no media data left. Is there a way i can transfer these too? i have many pictures in my Anki cards so the backup is more or less useless.

i would be so happy and thankful if you had any idea on what i could do.

You don’t bother at all!

This is really not my field of expertise but from what I know all text is stored in backups and all media in the “” folder. The data is there, though in seperate folders.

What I have done so far is to make a copy of the “AnkiDroid” folder that is stored on my computer if anything goes wrong in my attempt to get things working again. I don’t have to be afraid losing anything. My suggestion to you is to do the same!

There’re some ways to solve this presented on GitHub. I’ll try what Danika_Dakika suggested and get back to you with results.

1 Like

@Anki-Olau @Sunday
I think the final solutions have already been guided for you, but… I’m a bit concerned about something in this case. What Android version (for example, Android 13, Android 11, etc.) are you using?

I have Android 13!

1 Like

I see. Your case doesn’t seem to fall into my concern… but just in case, could you please show me the following “Storage permission” screen in your device?

Steps: long press the app icon > App info > Permissions > Storage

This is what I get. Nothing about storage though.

I also allowed “read and write to the AnkiDroid database” but it didn’t help.

1 Like

Thank you for the thorough check.

I see. Your case doesn’t fall into my concern. I hope you feel comfortable proceeding with the proposed solution.

1 Like

Thank for your time - you’re the one (among others) who’s helping me!

1 Like

This should go without saying, but – Don’t delete anything until you are reconnected with your collection!

Did you check the links I posted? They explain which is the “current” location and which is the “new” location (ichi2.anki). A “parallel” install from GitHub will get you access to your collection at the “current” location. Then sync that to AnkiWeb. Then return to your primary install and sync to AnkiWeb. That will bring your data to the “new” location that Anki can access.

[If you want to have a better understanding of what is what in your Anki data folder – Managing Files - Anki Manual .]


Dear Danika,
Thank you for your support. After hours of trying i managed to get everything in place so that i was able to restore everything with a backup and the collection media.
It was a bit complicated but if it should help with future problems or other users facing the same problem i will explain what i did and how it turned out.

1 Like

Great! Haven’t had the time to go with instructions yet that I’ve received here. How did you proceed?

It is a bit complicated to explain so may i ask, where your Ankidroid folder is saved first?
My problem was that i have an AnkiDroid folder and an AnkiDroid folder contained by the android folder (dont ask me how this happened or if it has always been like that but my Anki didnt have a problem with it until now…)

So when i checked yesterday the Ankidroid folder (Android (seen in the picture) > data > com.ichi2.anki > files > AnkiDroid) was empty while the AnkiDroid folder (seen in the picture) contained all the media data etc (you should see them if you click on the folder from your first picture)

If i were you and you have a Laptop/Computer just connect your phone via USB it is so much easier to look at all the folders and you can open several Tabs - it is less complicated like this.

Is your situation equivalent to mine ? then i can explain to you how i solved my problem. Otherwise (if you dont have 2 different AnkiDroid folders idk if i can help you)

I didnt uninstall Anki in the first place so if you did any of that idk if something changed for you. I also dont think that my solution is a safe longterm solution but i could do a sync with all the cards containing the media data via a backup so if AnkiDroid should have problems in the future i still have everything in AnkiWeb. But first i ‘repaired’ the Anki App

And i ‘repaired’ the AnkiDroid App from taking me to advanced settings by entering the App and changing /storage/emulated/0/AnkiDroid (Seen in your second Picture) to:
(You can click on AnkiDroid sökväg and copy paste it in there)

Now you should be able to go to the main Anki App page again (in my case it was empty without any folders).

Now check if the problem has gone away (it didnt in my place):

If the Problem should have solved itself you should be able to see all your back up data and can choose a backup from when your anki has still worked:

(I’m sorry my Anki is in german)

If it doesnt show you all your older backups then you need to transfer the AnkiDroid folder data to the right place or (if that isnt possible) delete the Ankidroid folder in your Android folder (only if you are facing the exact same problem as i did)

If you say you have the whole AnkiDroid folder saved on your computer (i wasnt able to transfer the whole folder with all the media in it) maby it is sufficient if you now enter your android > data > com.ichi2.anki > files and delete the AnkiDroid folder and put your saved AnkiDroid folder instead or if you put all the folders seen in your first picture into the existing AnkiDroid folder (i couldnt do that either because it wouldnt let me do that so i had to delete this Android AnkiDroid folder in order for the AnkiDroid App to use the other AnkiDroid folder (the one which was not in the ‘Android’ folder and where all my data was) again.

After doing all that i restarted the Anki App and did like in the 4 Pictures from above it showed me all my backups (see 4th picture) and after choosing a backup everything was back to normal.

(i then syncronized everything in the Anki App to my AnkiWeb in case it wont work anymore in the future)