Android Directory is Inaccessible (version 2.17.6)

As of today, I’m not able to access my AnkiDroid to study Japanese. I have researched this topic. It seems that some update at some time forced the AnkiDroid to use a different folder than it previously did.

I tried deleting the new folder, but it didn’t work.

I have tried looking for Storage Permissions, but that doesn’t seem to be an option for me.

I tried signing up for a beta version, but it doesn’t seem to have updated it.

No, I never synced my Anki, so it is all stored on my phone.

I don’t know how to install a new GitHub version, but would be willing to do so if someone would write out the steps, or something like that.

Does anyone know what I can do to cure this? Does anyone alternately know how long it will take for my phone to migrate the files?

Since you aren’t synced already, the easiest method is #1 (Full Storage Access · ankidroid/Anki-Android Wiki · GitHub) –

  • Backup your AnkiDroid folder
  • Install a github parallel build, which can still access the old file location
  • Sync to upload your collection to AnkiWeb, which it is good to be doing anyway, so you have a backup! (AnkiDroid 2.17 User Manual)
    • If you have a lot of media, it may take a few tries for all of your media to sync
  • Then in your main install, setup syncing to download your collection from AnkiWeb
3 Likes

Wait, please elaborate a bit more.

Do I need to uninstall my AnkiDroid? Won’t that cause the loss of all my files?

Do I need to download the Parallel.A in addition downloading the full-universal.apk ?

If I download full-universal.apk, does it automatically install it, or do I need to do something else once it finishes downloading?

No, don’t do that.

“Parallel.A” (or B, C, etc.) means that it will install alongside your other install – as opposed to updating your other install. The “full-universal.apk” is the installation file.

Whether it will auto-install depends on your phone, your Android version, your settings, etc. If it doesn’t self-start, you can find it in your downloads folder and run it from there. If you haven’t installed this way before, Android will ask for permissions to install from “other sources” that aren’t the Play Store. You can revoke that permission in your Android settings when you’re done with this process.

2 Likes

Thank you for the response! I had already downloaded Parallel.A by the time it was written … thankfully, I was able to get access to things, and I synced it, at least I believe I did. So … what I am supposed to do now, I’m not quite sure. My main Anki still says the directory is inaccessible.

Do I just start doing cards on the alternate Anki … ? If I do them, I suppose it won’t carry over to the main account? But if I back up the alternate account, I suppose I could still download it again when it starts working again.

What am I to do next?

If you go to Settings > Advanced – what is the “AnkiDroid directory” set to in your main version? Is it /storage/emulated/0/AnkiDroid?

Change that to /storage/emulated/0/Android/data/com.ichi2.anki/files/AnkiDroid. It should have changed over automatically, but storage migration has been skipped for some users [Storage Migration FAQ · ankidroid/Anki-Android Wiki · GitHub].

The point is that both the alternate Anki and the main Anki are going to sync to the same AnkiWeb account. You used alternate Anki to get the data there, and you’re using main Anki to get the data back. Then you won’t need alternate Anki anymore.

So for now, as long as you sync when you open and when you close the app, your collection will always be in sync.



Will you do me a favor when you get all of this settled? Go to Settings > About > Copy debut info – and paste that here. It’s still a puzzle why Storage Migration is getting skipped for some users, so that might be helpful.

2 Likes

Sure. I pasted it here. So … can I delete the alternate now? Or do I need to keep it around a couple days until this resolves?

AnkiDroid Version = 2.17.6 (568538896be943818ca793dd2635822265712def)

Backend Version = 0.1.34-anki23.12.1 (23.12.1 1a1d4d5419c6b57ef3baf99c9d2d9cf85d36ae0a)

Android Version = 14 (SDK 34)

ProductFlavor = play

Manufacturer = samsung

Model = SM-S908U

Hardware = qcom

Webview User Agent = Mozilla/5.0 (Linux; Android 14; SM-S908U Build/UP1A.231005.007; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/123.0.6312.121 Mobile Safari/537.36

ACRA UUID = 07d8d762-0b69-47dd-8916-981d1d232123

Crash Reports Enabled = true

If you have your main install set up and syncing, and it looks like you’ve gotten all of your decks and data and media – run a Check Database, and a Check Media to be sure. If that looks good, you can delete the parallel/alternate app.

Since you’ve already got a backup of your old AnkiDroid folder, it’s fine if you want to delete the /storage/emulated/0/AnkiDroid one to save space too. In few days, that backup will be outdated, but it’s always good to have a backup of your collection.media folder.

2 Likes

hi
i do have the same problem. last time it worked flawlessly, as it did for years. today no more usable due to this error (on Android).
am a bit lost what to do, although reading here. And also wonder, as quite a few people seem to have affected, if there will be a fix provided via App-Update ?
thanks

The same steps I described and linked to above should work for you as well.

It’s not clear why the automatic storage migration process isn’t working for a few folks, but if you also respond with your Settings > About > Copy debug info, that will help the devs gather information.

2 Likes

hm. i don’t get it and it still doesnet work. no tutorial for the not too tech savvy. used anki for several years every day - one day had to be the last one, had hoped i could decide that myself.
life goes on, a pity that devs let it end that way.
all the best

It’s unfair to the AnkiDroid devs for you to lay this at their feet – Google policy changes created this problem.

It’s unfair to yourself to give up using AnkiDroid because of this. But if it’s not important enough to you to even explain what you’re struggling with, then I suppose quitting is the only option left. When you’re ready to ask for help, this is a good place to get it.

3 Likes

In their very first post they asked for step-by-step instructions on how to install the GitHub version, and in your reply all you said was “Install a github parallel build.”

Their frustration is warranted.

I think you’re looking at someone else’s post.

W and P are two different letters that correspond to different people.

Yes.

W, the topic creator, asked for step-by-step instructions on how to install the GitHub version.

You, Danika_Dakika, replied by saying “Install a github parallel build.”

Good gracious! I’m not sure how this is any business of yours.

What I see there is me responding to that user by rewriting the instructions into 4+ steps – with multiple links for reference – and then answering their follow-up questions. They were happily able to resolve their issue.

I don’t know what you want from me here, but I also don’t really care about your opinion. If you don’t find my help useful, please don’t read it.

1 Like

We are here on a voluntary basis.

2 Likes

Yes, everything is currently working fine for me. With what you wrote as a guide, I was able to figure out what to do. I kept trying things while waiting for your next response, etc. So on the whole, I think this forum question of mine can help others who encounter this error successfully resolve it. In that way, I am glad that I asked.

2 Likes