Anki pulsation animation stopped working on mobile devices but desktop is okay?


I just wanted to ask especially regarding the TestFlight app if there were any changes regarding pulsation animations or else? I noticed that the effect stopped working on iPhone and iPad (was working until then) but on desktop it is still working?


Thanks !

Are you referring to something you have in your card template? Perhaps it’s related to this? Consider making reduce-motion and minimalist modes opt-in instead of opt-out · Issue #2557 · ankitects/anki · GitHub

correct, it is in my template

here is a vdeo

I think important snippets are:

.nightMode #ExtraNurText,
.night_mode #ExtraNurText
border: 20px solid red;
animation: border-pulsate 2s infinite;
border-radius: 10px;

@keyframes pulse {
0% {
transform: scale(0.95);
box-shadow: 0 0 0 0 rgba(217, 30, 24);, 1;
70% {
transform: scale(1);
box-shadow: 0 0 0 10px rgba(0, 0, 0, 0);
100% {
transform: scale(0.95);
box-shadow: 0 0 0 0 rgba(0, 0, 0, 0);

@keyframes border-pulsate {
0% { border-color: red; }
50% { border-color: rgba(0, 255, 255, 0); }
100% { border-color: red; }

does this help in terms of trouble shooting?

Thank you, I’ve made a note on that ticket. It might take me a while to circle back to this I’m afraid.

thanks ! please inform me, so I can check if it works, when you had time to revisit

I uploaded a beta yesterday which may address this. After updating to it, do you still get the problem?

I just updatet the testflight version, the problem still persists

I tested it on a simple card template and the flashing worked correctly, so the issue probably lies somewhere else in your card template. I recommend you try cutting out parts of your template to isolate what’s causing the problem, after confirming you can’t reproduce the issue in a simple front/back with that styling added.

thanks for the tipp. I tried that and could figure out the error within my template. Can be closed :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.