Anki opens only as background process

Hi everybody,

when I try to start Anki (also when holding down the shift key) nothing happens, but when I look in Task manager a new background process appears called “anki.exe”, when I try again another background process appears and so on.
I tried the steps described here: Some Programs Only Open as Background Processes - Microsoft Community → nothing needed to be repaired.

I installed Anki version 2.1.48.
I deinstalled 2.1.48 and installed 2.1.44.
I deinstalled 2.1.44 and installed 2.1.48.

I tried everything described here: When Anki doesn’t start on Windows (debugging steps) - Frequently Asked Questions ( and I get no error message, it just seems to be running fine in the background:

I restarted my Computer basically after every step above.

I checked my Computer for malware with Kaspersky Total Security.

I’m running the latest version of Windows 10 (21H1).

I’m a poweruser using Anki every single day, during lecture periods (luckily didn’t start yet) many hours a day, so I’d be very grateful if somebody could help.


You could try the following basic debugging steps, and report if the result seems interesting:

  1. if you have an other computer accessible, you could try to install Anki in the exact same way and see if it works or not

  2. you could try installing a previous version, for example 2.1.47.

  3. check if the Qt libraries are really working, for example by launching an other app that requires Qt 5 and PyQt 5. Just as a basic test, you could try, in a python shell

from PyQt5.QtWidgets import QApplication, QLabel
app = QApplication([])
label = QLabel("it works!")

You could try running from Python directly:

It may also be worth trying to run Anki while Windows is in safe mode, or temporarily remove antivirus programs to see if that helps.

1 Like

Thank you, running from a virtual environment (I used conda) worked! Learning a bit of python/environment management is starting to pay off even as a medical student ^^