ANKI Not Starting (Possible clues to an older post)

NOTE: I got it finally got it started, but thought I may have some clues for the developers as to what was going on.

ANKI VERSIONS: 23.12.1 QT5/QT6, 24.04.1 QT5/QT6

Was running 23.12.1 (not sure of QT).
Upgraded to 24.04.1 QT6.
Noticed some issues with filters not respecting the “Reschedule Cards=no/unchecked” flag and I wanted to go back to 23.12.1.
Installed 23.12.1 QT6. Would not start. Rebooted.
Uninstalled. Rebooted.
Installed 23.12.1 QT5. Would not start. Rebooted.
Uninstalled. Rebooted.
Installed 24.04.01 QT5. Would not start. Rebooted.
Uninstalled. Rebooted.
Installed 24.04.01 QT6. Would not start. Rebooted.

Tried to follow this post:
  1. I had 24.04.01 QT6 installed last, so continued from there.
  2. Installed Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017, 2019, and 2022 for X64
    Rebooted. Did not start
  3. Installed Process Monitor, added ANKI.EXE per screenshots
    No activity reported.
    As a test, I added a filter for EXCEL.EXE and got a log of events,
    so I “think” I am setting it up right. (Yes, I set is as a Process Name
    and not the default "Architecture :wink: )
    NOTE: I later got this to work, but needed a FILTER RESET.
  4. Looked a bit further and tried (from a CMD shell)
    Got this (nearly the same as in the post)
Anki starting...
Initial setup...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "aqt", line 52, in <module>
  File "aqt.gui_hooks", line 11, in <module>
  File "_aqt.hooks", line 18, in <module>
  File "aqt.qt", line 20, in <module>
  File "aqt.qt.qt6", line 12, in <module>
ImportError: DLL load failed while importing QtCore: The specified module could not be found.
Press any key to continue . . .

Could not get any version to start …and I wasn’t ready to start down the Python path. :roll_eyes:

The “DLL load failure” message bothered me. So after I used the uninstall from Remove Programs + Reboot, I went to the ANKI directory. I expected it to be fairly empty, but there was a lot of baggage left.
I went to the QT6 directory and deleted all the .dll files.
Reloaded 24.04.1 QT6 and it started!

I uninstalled it + Reboot, and loaded 23.12.1 QT6. No start.
Uninstalled it. Rebooted.
This time I just deleted the whole QT6 (was still be there) subdir and its children .
Installed 23.12.1 QT6 again. Fired right up.

So I wonder if there MAY be an issue with the uninstall process not being 100% clean?
You tell me,I don’t know the code. :wink:

After I test 23.12.1 for the filter’s “Reschedule = “no” not being respected” issue, I will try to see if I can capture anything with Process Monitor, now that I have it working.

I am in no way complaining or pointing fingers. I just thought this might give you some clues.
Thanks for “listening”.

1 Like

In recent times, the installer keeps a record of what has been installed, and uses that to remove old files. Old installers did not keep such a record, so the files that were lying around are probably from an older installation. Glad to hear you were able to get things working in any case!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.