My Anki doesn't open/start

Hey guys!

I just installed Anki 24.06.2 Qt6, however, it doesn’t open, nothing just appears.

When I look in the “Task Manager”, anki.exe appears there and is running, but nothing happens, it doesn’t start.

I’ve tried installing previous versions and it’s still the same.

Does anyone know what can it be?

Start by going through the Troubleshooting Checklist – Troubleshooting - Anki Manual – to narrow down the issue.

If it doesn’t get better, when you respond again, include the info from – Help > About > Copy debug info.

1 Like

No, man, don’t solve it.

Most of these steps in the link you provided require opening Anki, how will I do it if I’m not even opening it?

My Anki appears in the “Task Manager”, but it doesn’t open, it doesn’t show an image, it doesn’t start.

can you start anki directly in the command prompt and post the output here?
also, make sure to force close the app first in task manager

No, how do you do it?

Win+R, type “cmd.exe” and press enter. Then type “%LOCALAPPDATA%\Programs\Anki\anki.exe” in the command prompt (assuming you used the default installation directory)

1 Like

Exception in thread Thread-1:
Traceback (most recent call last):
File “threading”, line 980, in _bootstrap_inner
File “aqt.mediasrv”, line 85, in run
File “waitress.server”, line 78, in create_server
File “waitress.server”, line 229, in init
File “waitress.trigger”, line 171, in init
TimeoutError: [WinError 10060] Uma tentativa de conexão falhou porque o componente conectado não respondeu
corretamente após um período de tempo ou a conexão estabelecida falhou
porque o host conectado não respondeu
Exception in threading.excepthook:
Exception ignored in thread started by: <bound method Thread._bootstrap of <MediaServer(Thread-1, started 11952)>>
Traceback (most recent call last):
File “threading”, line 937, in _bootstrap
File “threading”, line 982, in _bootstrap_inner
File “threading”, line 1264, in invoke_excepthook
AttributeError: ‘ErrorHandler’ object has no attribute ‘flush’
Exception ignored in sys.unraisablehook:
AttributeError: ‘ErrorHandler’ object has no attribute ‘flush’

Network issue. Try removing proxies in your system config and/or resetting the network adapter settings.

1 Like

Sorry for my ignorance, but could you tell me how to do it?

Did you try #2 – starting Anki while holding down Shift (until you see the confirmation message)? Can you try that while running it from the command line (hold down shift before pressing Enter) – to see if the message is different? (Make sure you’ve killed the Anki that is running first – restart your computer if possible.)

As voczi said, a network issue seems likely – but (1) that shouldn’t be an issue with a Shift-start, because Anki won’t try to reach the network, and (2) it’s hard for anyone to troubleshoot that from the outside. We don’t know anything about your system. Which leads me to –

  1. What OS version are you on?
  2. Was this a fresh install (on a computer that didn’t have Anki before), or an upgrade from a prior version?
  3. If it was an upgrade, did you have any add-ons installed and active? Do you know what version you upgraded from (approximately)?
1 Like

Yes, I tried, including in the video I’m attaching I did by holding shift.
Nothing appears, Anki shows no sign of life.
1 - Windows 10 Pro 22H2
2 - It is the new version of Anki, 24.06.2 Qt6.
I had formatted the computer before, then when I installed it, this happened.
The quality of the video was too bad to be uploaded here.

Did you make sure those processes – the main Anki exe and the QT processes – were all killed before you tried that? (A video almost never helps, unless what you’re describing is something that is happening in motion.)

Have you tried uninstalling and installing the Qt5 version? Have you tried installing the last version you know worked on this machine (before you formatted it)?

Check these items as well – Startup Issues - Anki Manual .

Yes, I tried, including in the video!

Click in video:
Video installing

I’m not interested in watching another video, especially when you’ve given me no information about why I would need to. You can just answer the questions I asked.

I answered him, said yes, I tried.

  • I tried installing the version of Qt5 and even the one that was working.
  • I have no addons installed as it is a zero install.

In this new video I show the installation of Anki that was working before formatting and how it no longer works.

So that no one else will need to watch the video – fresh install of 2.1.65 Qt6 gives the same error/hang on open.

Relevant screenshots from the video --

Thank you for trying 2.1.65. Since it’s happening on older and newer versions, it seems more likely that it is a conflict in your system. Are you certain that what you had installed and working before formatting was Qt6 and not Qt5?

If you’ve tried everything suggested so far, and nothing has helped, this still seems likely to be networking related – since that’s often suggested for this exact error –

Another possibility is mpv/mplayer conflict (additional suggestions further down-thread) –

I just did a test:

  • I installed VirtualBox, then the same Windows and installed the most up-to-date Anki possible, it worked.

I don’t know if it’s my machine that is blocking the network for Anki, do you know how to activate/release it?

I have the same problem. I force quit Anki in the task manager to fix it temporarily.

Appears to happen arbitrarily. I was think I’d start by reinstalling windows, but haven’t done it yet.

Haven’t tried trouble shooting other than the basics referenced above.

My forced close in the Task Manager doesn’t work, it simply doesn’t start.

I did the test above, and Virtual Machine on the same Windows, and it works normally.

Oh, then I guess it’s not the same thing. My bad.