Anki Desktop Annoyance

Hey everyone,

With the new update, every time I open a new desktop (not window) on my laptop Anki moves over to the other desktop (say desktop 2) when I initially opened it on desktop 1. Is there a solution to be able to keep the Anki desktop app from moving to every single desktop I open because it really ruins my productivity?

I’m not able to reproduce this. Would you mind making a short video that demonstrates what you’re doing?

Hi there, I provided a link to a video I uploaded. Sorry for the late response.

Here is a youtube link that shows the problem more clearly.

Thanks for that. I’m not seeing that behaviour here - does it happen if you start Anki while holding down the shift key to disable add-ons? If so, could it be related to any of the apps you have runnnig in the menubar at the top right?

I tried both holding down the shift key and disabling my windows app that I have separately and together and the problem is still occurring. Should I try deleting the app and redownloading it? This never happened with the old 2.1 version of Anki.

That won’t help, but one thing you could try is to close Anki, then temporarily rename your prefs21.db file. Does that make any difference?

It did prompt me to choose the language of the app once I changed the file name but the problem keeps occurring. I also tried it by disabling my window app and holding down the shift key but it still didn’t work. It’s pretty weird since this is the only app that this problem is occurring on.

Perhaps you changed the settings in the dock?,show%20up%20on%20all%20desktops.

OMG, thank you it fixed it!! Haha, I feel really dumb about that.

Glad to hear that resolved the issue!