Anki desktop 2.1.9 not running / synching

Hi there,
I have a problem with my Anki desktop 2.1.9 on Windows 10 (64 bit).
Launching the program, it shows me the following sentences (traslated in english)

“Failed to synch:
Traceback (most recent call last):
File “aqt\”, line 348, in run
File “aqt\”, line 414, in _sync
AttributeError: ‘Syncer’ object has no attribute ‘hostNum’”

After closing that:

“Your Anki client does not support the new timezone handling yet. Please ensure your Anki is up to date.”

Then, sometimes (1/6 or less) anki starts, the majority of times it freezes.
When it starts, it won’t synch, no matter what I do.

I tried uninstalling and re-installing several times, doesn’t work.
Pc time has been set to automatic.

I tried the downgrade to version 2.1.49 or lower, they start in the background (I can see them in the task manager) but never become active, I can’t see them not even minimized.

Is there a solution to that?

Thank you for your support, anki is such a powerful tool and I really would like to continue using it

I might have misunderstood, but you are “downgrading” from 2.1.9 to 2.1.49?

You should upgrade to 2.1.49.
In case there is a misunderstanding: 2.1.49 is the higher/newer version (and in fact the newest version at the moment).

Thank you for your replay.
How is 2.1.49 newer than 2.1.9?
Anyway, I tried also with 2.1.49 and, as previously explained, 2.1.49 starts in the background and it doesn’t become “active”, meaning I can’t see the interface nor the icon on the bar of application, I just see “anki.exe” in the task manager.
I tried to use compatibility mode fore windows 8, vista, etc but it doesnt work.
I’ve run out of ideas.
If you have any, I’ll be glad to follow your advice :pray:t2:

You have to think about is as three individual numbers: 2, 1, and 49. If any of those numbers increases, it’s a newer version. For more information, google “semantic versioning”.

For why it doesn’t start, it’s hard to help without any error message. Maybe someone else has an idea.

Ok, now the numeration is clearer, I thought it was like 2.1.90 vs. 2.1.49.
I don’t have any error message, it simply doesn’t show up (except for the task manager) when I launch the application…

Please see Startup Issues - Anki Manual

1 Like

Thank you!!! I didn’t see that part of the manual

Apparently the problem was my decimal separator, the problem solved by setting it to a coma instead of a period (in the manual it seems to be the opposite, but it worked that way in my case :man_shrugging:)
Thank you again!!!