Anki Crashes when Trying to Import

Hi, I’ve been having an issue importing a deck that my friend made. We are both using the same version of Anki, use the same add-ons, and have been sharing cards back and forth for weeks now without issue. When I click on the downloaded apkg, my anki just quits/crashes. However, when I made a new profile and imported the same apkg to that profile, it worked. Just wondering what could be causing this crash specifically in my current main profile? I have tested by importing other decks into my main profile and I am able to do so, it is just this deck my friend made in particular that is causing my anki to crash.

Thanks in advance!

Do both the standard and alternate 2.1.33 version of Anki crash for you? If you run anki-console, is any text printed as it crashes?

I spent the whole quarantine making a huge deck, only to find that it crashes everytime I import it into another profile. (Which means that it will sure crash in other user’s pcs too.)

This Anki software is the savior, and yet the absolute bane of my existence.

It seems that in an empty profile I get a “crash for 2min but then get back to working”. I can import the deck.

But on my main profile, it crashed completely, I waited for 10min for the crash to go away, closed Anki with Task Manager, then loaded Anki up again and I saw that despite the crash, the deck loaded. It seems that it loaded completely. (I’m using 2.30)

By crash, I guess you mean “freeze”? On a large deck it’s not hard to imagine an import taking more than 10 minutes on some computers. There have also been instances where an add-on tried to present a message during the import which caused things to get stuck - if you use add-on its may be worth trying to disable them to see if the issue persists.