Crash when Importing Deck on Mac

Hello all, I am desperately seeking help on how to import a deck into my anki. The deck is in a “.apkg” file that I have confirmed is able to be imported when I created another profile to test this. However, it will not import into my main user profile that already has another deck in it. Whenever I attempt to import the new deck, I am stuck on a “processing” screen that then eventually closes and I am left with the Mac spinning circle of death with “application not responding” until I force quit the application after waiting over an hour. I am updated to the latest version of anki, I have “checked database” for optimization, and I have no error messages that appear. Any idea what I may be doing wrong/how to fix this? ANY help would be enormously appreciated.

What happens when you try import it into the latest Anki version?

I updated to the 2.1.30 version today. After doing this, on import I received the following error message:

Import failed. Debugging info:
Traceback (most recent call last):
File “aqt/importing.py”, line 404, in on_done
File “concurrent/futures/_base.py”, line 432, in result
File “concurrent/futures/_base.py”, line 388, in __get_result
File “concurrent/futures/thread.py”, line 57, in run
File “anki/importing/apkg.py”, line 44, in run
File “anki/importing/anki2.py”, line 41, in run
File “anki/importing/anki2.py”, line 64, in _import
File “/Users/me/Library/Application Support/Anki2/addons21/880042638/init.py”, line 249, in newImportNotes
b = json.loads(models)
File “json/init.py”, line 357, in loads
File “json/decoder.py”, line 337, in decode
File “json/decoder.py”, line 355, in raw_decode
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

I have NO idea what this means. Any thoughts?

this error is for when you install an older version without pressing Downgrade & quit button on the newer version that you had previously installed.

can you try installing the latest version of anki and then try to import the deck?
if it didn’t work, try installing the latest beta

It looks very similar to the issue mmdj describes, but this one is actually caused by https://ankiweb.net/shared/info/880042638 - you will need to disable or remove it.