Anki App will not open

I recently got a new mac and Anki simply won’t open. I’m running OS Monterrey and have tried some versions since 2.1.2 upwards of the latest release. I’ve tried deleting and redownloading the application multiple different times. Below is the error message in detail

I’m not sure what else to do, any help would be greatly greatly appreciated.

Thank you

Translated Report (Full Report Below)

Incident Identifier: 5F4475A1-921A-43B0-B575-3316F91B9823
CrashReporter Key:   797657C8-874D-0F1A-68C8-7EE4E6A86379
Hardware Model:      MacBookPro18,3
Process:             AnkiMac [29592]
Path:                /Applications/
Identifier:          net.ankiweb.dtop
Version:             2.1.49 (???)
Code Type:           X86-64 (Native)
Role:                Background
Parent Process:      launchd [1]
Coalition:           net.ankiweb.dtop [31050]

Date/Time:           2021-11-17 21:38:22.8862 -0600
Launch Time:         2021-11-17 21:38:18.2170 -0600
OS Version:          macOS 12.0 (21A344)
Release Type:        User
Report Version:      104

Exception Codes: 0x0000000000000001, 0x00007ff7fff0faf0
Exception Note:  EXC_CORPSE_NOTIFY
Termination Reason: SIGNAL 5 Trace/BPT trap: 5
Terminating Process: exc handler [29592]

Triggered by Thread:  0

Application Specific Information:
rosetta error: /var/db/oah/279281322164224_279281322164224/1d455f9bbcab7b57fb1648d396a5c120f969389df0a4e088ecc1942240ac489d/AnkiMac.aot: attachment of code signature supplement failed: 1


Looks like a macOS bug - some brief googling seems to indicate a reboot will likely fix it.

1 Like

I am having the same issue - I too have just downloaded the app onto a new MacBook Pro (M1 Max) and the App won’t open. It bounces once or twice in the doc then stops. I have tried rebooting. I have tried starting it whilst holding down the shift key.

1 Like

Tried updating to macOS 12.0.1?

1 Like

I just deleted the application, upgraded to 12.0.1, and reinstalled anki which worked. Thank you!

1 Like

Thank you, deleting and reinstalling has also fixed the problem on my machine. I must have upgraded the OS in the meantime as my computer is on version 12.0.1.

If I try deleting my current Anki app and redownloading, will I lose all my cards and progress? I am not sure how to back them up and I did not back them up or save them externally before I started having issues with Anki opening after updating the app

The program data and your card data are stored separately, so your cards will remain after removing/reinstalling the app.

deleting it and re-downloading it didnt work