Anki 2.1.50 Beta 6+ / Release Candidate

I received the following error while reviewing:

Anki 2.1.50 (742e4a5c) Python 3.9.7 Qt 6.2.3 PyQt 6.2.3
Platform: Mac 12.2.1
Flags: frz=True ao=True sv=3
Add-ons, last update check: 2022-03-23 08:31:58

Exception ignored in: <function HttpClient.del at 0x105e30ca0>
Traceback (most recent call last):
File “anki.httpclient”, line 47, in del
File “anki.httpclient”, line 43, in close
File “requests.sessions”, line 737, in close
File “requests.adapters”, line 326, in close
File “urllib3.poolmanager”, line 222, in clear
File “urllib3._collections”, line 100, in clear
File “urllib3.poolmanager”, line 173, in
File “urllib3.connectionpool”, line 496, in close
File “http.client”, line 959, in close
File “socket”, line 501, in close
File “ssl”, line 1300, in _real_close
File “socket”, line 495, in _real_close
OSError: [Errno 41] Protocol wrong type for socket
Exception ignored in sys.unraisablehook:
AttributeError: ‘ErrorHandler’ object has no attribute ‘flush’

FYI I was using as still-in-development add-on at the time. I don’t believe it to be related but the stack trace isn’t clear about where it’s originating.

I tried to check which beta I was using but I couldn’t find 742e4a5c in the list - am I right in thinking it’s the removed Beta 7? I’ve now downloaded the latest version.

When adding cards, sometimes it happens that the cards are not added in order. This is considered a serious bug. If you test it, you may see the problem recur from time to time.

image

I found the cause of the bug.

When creating a new card, the card with Due number 0 is created as shown in the picture above, so even if the cards are set to appear in the order they are added in the custom study study, the card with Due number 0 appears in an odd order.

In conclusion, when adding a new card, Due should not be added as New #0.

I hope to test it once and let you know the result.

This is a bug that must be fixed.

For reference, I do not use addon, I use beta9 version of V2 scheduler.

The second thing I’d like to suggest is that the images on the card appear too small in the browser.

If you click the image and click the button on the far right, it will be the original size, but if you select another card, it will be reduced again.

I check the image on the front of the card in the browser and write the answer on the back of the card, but I feel inconvenient because the image is too small.

What I would like to suggest is, could you put a feature in the browser to fix the image to its original size?

I’m not sure having them at full size by default is best, since it’s hard for the program to know the right scale for each image and it’s much harder to see the fields if there’s a big image filling up the screen.

@hanbin

Thank you for the report, a fix will be in the next build.

Re release date, please see the top post.

@hengiesel is most qualified to answer this one.

Did you download/update any add-ons since you started Anki? If not, an add-on is probably using Anki’s HTTP client.

Short answer: Use Cmd/Ctrl+Shift+T.
Long answer: Normally (in the browser) tab focuses each element on the site that can receive input. This includes all visual elements, and includes buttons. In the Anki editor, it only focuses fields, but skips the editor buttons. The reason the tag section is skipped, is that there’s no good focus target available. Maybe what you’d expect is a new open tag to be focused, however the visual element for this new tag is only created when you click the tag icon, or click the space to the right of the last tag. Before clicking it, it doesn’t exist, so it cannot be focused.

You can also double-click images, to restore their original size (we could add this to the tooltip).

I think this is perhaps a new bug in recent betas:

On Ubuntu when I activate the tag line, no cursor shows up, nor does the tag line show letters as I type. The only indication that anything is happening is the popup that appears after typing which allows me to choose between existing tags.

I’m using this version (beta 9):

Version 2.1.50 (4515c41d)
Python 3.9.10 Qt 5.15.2 PyQt 5.15.5
1 Like

Could you provide a screenshort? Have you made sure that add-ons are disabled?

You can make the original image size by double-clicking, but if you select a different card, it will appear reduced again.

It would be good if the original image and small image could be changed so that the user can fix it as desired.

Specifically, if you double-click to create the original image size, it is automatically applied to other cards.

I don’t know if this is the place to make suggestions. If no, please, tell me @dae . But I would recommend dividing Cloze bottom in two:

  1. New cloze (CTRL + SHIFT + C)
  2. Same cloze (CTRL + SHIFT + ALT + C)

And make it a litlle bigger ansd more intuitive
image

I know that you are in a hard work now. Thank you for that.

1 Like

Not that I remember definitely didn’t update or install any in that session. Hasn’t occurred again, but I’ll keep an eye on it.

Bug report:

  • Version Beta 9 (QT6) on Manjaro Linux KDE (latest stable).
  • No Add-ons !

Anki freezes when I click “Browse” > Added Today > Click over some cards (e.g. Dieb)

I was trying to Browse my added cards to preview them but it is impossible. Anki collapses before being able to preview after clicking the card “Dieb” or any other card.

I can share my deck publicly to allow others to reproduce the bug on my deck:
email: ankiweb.xr2yb@simplelogin.co
Password: WXDk85mEhVezfnb6VXZiuiofhnMCy3QApH8RQ8emfm4qswB4rczNHVfZCVyr

The CPU usage increases until 100% in few minutes and RAM also increases. I reproduced the issue with and without add-ons. It seems a regression.

Thanks, added to Certain field content causes HTML editor to get stuck in infinite loop · Issue #1740 · ankitects/anki · GitHub

The last blocker i’m experiencing with Anki 2.1.50 betas is problems interacting with the Editor Javascript API, I’ve described the issue i’m experiencing here: 2 addons conflicting with Svelte components (editorToolbar.toolbar.insertGroup) - #9 by hengiesel

It has already been added to the issue tracker:

2 Likes

I’m not sure if this comment was a reply to me, but here’s a screenshot anyhow. This is the “Add” window with the tag bar activated. There’s no cursor or anything:

When I start writing, letters do not appear, but a popup box allows me to select from existing tags based on what keys I’ve been pressing:

EDIT: And yes, this is with no add-ons enabled (SHIFT held down during startup).

I can’t seem to reproduce that on a Linux system here. The popup appears a bit higher here; my guess is for some reason, the text input is a line lower and thus cut off from view. Does it happen in the Qt6 build as well? Can you try previous betas to figure out where the issue was introduced? Does changing the high DPI settings make any difference?

I use the Anki2.1.50 beta9 in my m1 macbook air
when I use my own note type to add a new car. I can not input anything by using the chinese input method, while using the english input method do well


sometime it happen, and sometime it do work normally
acutally when I use ⌘ + ⇥ to switch another app, then switch back to anki, it do work normally :slight_smile:

If it’s any help, I’m running a rather unmodified Ubuntu 21.10 (using X, not Wayland).

Can you try previous betas to figure out where the issue was introduced?

Sure, just went over the betas for 2.1.50. The problem only appears in beta 8. It wasn’t there in beta 6. (It seems there was no public beta 7.)

Does it happen in the Qt6 build as well?

I’m unable to run the Qt6 build. As reported earlier, it fails to install.

~ fiddles with keyboard settings ~

Oh, I just now managed to install the Qt6 version of beta 9, and that doesn’t have the problem. So I guess it’s solved for my part for now :slight_smile:

A release candidate is now available. It includes an important fix for the card layout screen:

https://betas.ankiweb.net/anki2.1.50.html#release-candidate-1

@eyetofreedom This is a bug in the graphics toolkit. I have reported the issue to them. For now, the Qt5 version may work better for you.