Anki 2.1.55 Beta 5-6

Hi all,

A new 2.1.55 beta is now available:

Please let us know how it goes for you. A new stable release is hopefully not far off at this point.

Previous thread: Anki 2.1.55 Beta 3+

Linux users: for beta 5, please run the following commands within the untarred folder before attempting to run/install:

chmod a+r ./lib/anki/
chmod a+r ./lib/google/_upb/
chmod a+r ./lib/orjson/

This step is not required in beta 6.


Anki does not open. Btw I run KDE unstable …

Anki starting…
Initial setup…
Traceback (most recent call last):
File “”, line 1, in
File “aqt”, line 39, in
File “anki.lang”, line 12, in
File “anki._backend”, line 15, in
ImportError: /usr/local/share/anki/lib/anki/ cannot open shared object file: Permission denied
sudo anki
[sudo] password for chris:
Anki starting…
Initial setup…
Running with temporary Qt5 compatibility shims.
Run with DISABLE_QT5_COMPAT=1 to confirm compatibility with Qt6.
Preparing to run…
Qt warning: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’
Command ‘dbus-send --session --print-reply=literal --reply-timeout=1000 --dest=org.freedesktop.portal.Desktop /org/freedesktop/portal/desktop org.freedesktop.portal.Settings.Read string:‘org.freedesktop.appearance’ string:‘color-scheme’’ returned non-zero exit status 1.
Qt info:

GL Type: desktop
Surface Type: OpenGL
Surface Profile: CompatibilityProfile
Surface Version: 4.6
QSG RHI Backend: OpenGL
Using Supported QSG Backend: yes
Using Software Dynamic GL: no
Using Multithreaded OpenGL: yes

Init Parameters:

  • application-name Anki
  • browser-subprocess-path /usr/local/share/anki/lib/PyQt6/Qt6/libexec/QtWebEngineProcess
  • create-default-gl-context
  • disable-features ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture
  • disable-setuid-sandbox
  • disable-speech-api
  • enable-features NetworkServiceInProcess,TracingServiceInProcess
  • enable-threaded-compositing
  • in-process-gpu
  • use-gl desktop

[2247:2247:1123/] Running as root without --no-sandbox is not supported. See 638180 - chromium - An open-source project to help move the web forward. - Monorail.

Dang, please try chmod a+r lib/anki/ before installing.



The zoom level gets reset whenever the view window is updated.

I reported this bug in the beta 2 thread, but I think it was overlooked.
In the new importer it is no longer possible to import tags without zooming out (last row is hidden by the bottom bar).



If you zoom out it becomes visible

Thanks for the reminder. I wanted to tackle the CSV import window for some time now, but didn’t get around to it yet. If I can’t make it by release, it will certainly come with a patch shortly after.

1 Like

Nice to have a new beta!

Windows10 qt6

Options window:

  • when not large enough to fit two columns: the left and the right chevrons are asymmetrical, the right one being a little too high.


  • if the Options window is large enough to fit two columns, the right chevron “disappears” (you cannot click on it). The problem persists even if you scale the window down.


Checking with webview inspector, the left and right buttons appear to have a slightly different CSS

button.left.svelte-1cm9jh7.svelte-1cm9jh7 {
    top: 0;
    right: auto;
    bottom: 0;
    left: 0;
    border-right: 1px solid var(--border);
button.right.svelte-1cm9jh7.svelte-1cm9jh7 {
    position: absolute;
    right: 0;
    left: auto;
    border-left: 1px solid var(--border);

Deleting position: absolute; and adding top: 0; bottom: 0; to the right button’s CSS seems to fix both problems.

  • If you keep the left/right button pressed, you can set e.g. News cards/day and Maximum reviews/day to values below 0 and above 9999. If you set a negative value and then click on Save, some small bug may happen e.g.
1 Like

Thanks for the new beta!

Version ⁨2.1.55 (b88a7394)⁩
Python 3.9.15 Qt 6.4.0 PyQt 6.4.0
macOS 12.6.1

  • If the theme is to follow the system presentation, it uses dark mode even though the system does not use it.
  • In browse view, the whole screen flickers sometimes.
  • Adding a tag results always in another empty tag added. When this tag is clicked away, another empty tag is created.
  • The tag bar in browse view moves around vertically.
  • Nested tags are often truncated (…::last tag) in browse view.
  • Interface elements (especially the editor) in browse view sometimes appear delayed (up to a second).

Thank you for the information. I was thinking that would not be solved haha

Are these links supposed to be there?

Same here.
Windows 11. Qt6.

Zoom with Ctrl +
Click in Decks tab.

In some places the font is too big like in the decks browser, stats and deck options

Also, the edges of the tabs are again reversed in RTL. Attached is an example image from “Preferences”

Also the QComboBox arrow



The layout menu in the browser cannot be translated

In the deck browser, apart from the huge size of the text in the top bar - its order has been flipped so that the deck browser appears on the left instead of the right. Also, the size of the top bar does not change when you press control + mouse wheel.
The decks were also flipped from left to right

That’s it for now…
It seems that in the context of RTL there was a very serious retreat from the previous beta.
Thanks for the trouble and investment.

Curious. All these issues have already been addressed… I wonder why they reappeared now :confused:

My first guess is it’s due to the build system changes.

I’m sorry this beta is taking longer than anticipated. Last two weeks were impossible for me to work on Anki.

Thanks for the report!

I’m not seeing the mentioned issues here. Please double-check the build hash in the preferences screen, in case you accidentally downloaded the wrong version or opened a previous install.

If you’ve confirmed the build hash is the same, what does the following in the debug console report?



Weird behaviors in deck options page when using trackpad on desktop

  • The page scrolls weird if you use the trackpad to scroll to screen end.
  • When you zoom in using trackpad, dragging scrollbar to scroll doesn’t work well. The scrollbar is often unpressed when you drag the bar fast

I’ve updated the initial post; there are two other files that you should change too to improve performance.

I believe this was covered in a previous thread - the zoom is deliberately reset when moving back to the deck list.

Thanks, fix coming.

Is there a pattern to it so that we can try to reproduce? Can you reproduce it with the Qt5 version?

Yes, as mentioned in the change notes, the wheels (whl) are posted there for this beta.

@kleinerpirat these look like accidental regressions:

1 Like

I didn’t encounter any of the problems -rtl- in the last beta either

But that rule is still here :thinking:

The scrollbar regression is caused by the body in the deck options window not having a platform-specific class.

E.g. in the editor:

<body class="isLin nightMode night_mode">

but in the deck options it’s just <body>.

I’m on it (altough I don’t know how to go about the first one).

1 Like

Setting it on html instead of body seems to fix it on that page and others like stats - would it cause any problems to add it below the overflow-x in _base.scss?

1 Like