Anki 2.1.50 Beta 6+ / Release Candidate

Yes, I always do the test without any add-on when I test (beta8 qt5)

I read the link you gave me, but is it normal for V2 not to have ctrl z after the flag?

As a result of testing with version 2.1.26, flagging and undo worked well even in V2.

However, in version 2.1.50, it was confirmed that flagging and undo did not work in V2.

I wonder if this is a bug or not.

I encountered something similar with some earlier release, but it was not reproducible. Refreshing the screen made all remaining day mode elements update to night mode properly, so I don’t think it matters much, and I’m not sure it can be fixed within Anki.

would it be possible to get an updated GitHub - hgiesel/anki_new_format_pack which works with beta 8 ?

Beta 8 seems to fix addFile, and overall it’s working without an issue on by special 2.1.50 branch for AwesomeTTS. I do run into an issue without DISABLE_QT5_COMPAT=1 because AwesomeTTS tries to find certain widgets in the dialog and the classes don’t match (due to the compatibility layer) but i should be able to sort this out.


A serious issue with the ‘change notetype’ function has been discovered in beta3+, which could cause card template of cards you hadn’t selected to be changed when changing the position of more than one card template at once. Please avoid using the feature until beta 9 comes out.


Beta 9 is now available: Changes in 2.1.50 - Anki Betas


Did you have a good day today? dae.

I know you’re really struggling to fix the bugs in the new 2.1.50 version.

I wonder if the official release of version 2.1.50 is nearing.

If there is a new bug, the official release date will be delayed, but can you give an approximate release date?

Slightly inconvenient that it seems not possible now to select all (any 1+ group of) a card’s/note’s tags for, say, C&Ping to another.

(iirc it used to be possible to trigger a “conversion” of the browser’s tag line to a plain text one through certain edit actions – like clicking on the invisible text field next to the rightmost tag and hitting sth. like C+a or C+S+←)

edit: Possible bug: Right clicking on an existing tag offers to copy, but pasting that reveals that that’s a nop (nothing was copied/clipboard stayed unchanged).

In the editor, Tab takes me from the last input field to the search field at the top of the card browser. Why does it skip the tag section? @dae

I received the following error while reviewing:

Anki 2.1.50 (742e4a5c) Python 3.9.7 Qt 6.2.3 PyQt 6.2.3
Platform: Mac 12.2.1
Flags: frz=True ao=True sv=3
Add-ons, last update check: 2022-03-23 08:31:58

Exception ignored in: <function HttpClient.del at 0x105e30ca0>
Traceback (most recent call last):
File “anki.httpclient”, line 47, in del
File “anki.httpclient”, line 43, in close
File “requests.sessions”, line 737, in close
File “requests.adapters”, line 326, in close
File “urllib3.poolmanager”, line 222, in clear
File “urllib3._collections”, line 100, in clear
File “urllib3.poolmanager”, line 173, in
File “urllib3.connectionpool”, line 496, in close
File “http.client”, line 959, in close
File “socket”, line 501, in close
File “ssl”, line 1300, in _real_close
File “socket”, line 495, in _real_close
OSError: [Errno 41] Protocol wrong type for socket
Exception ignored in sys.unraisablehook:
AttributeError: ‘ErrorHandler’ object has no attribute ‘flush’

FYI I was using as still-in-development add-on at the time. I don’t believe it to be related but the stack trace isn’t clear about where it’s originating.

I tried to check which beta I was using but I couldn’t find 742e4a5c in the list - am I right in thinking it’s the removed Beta 7? I’ve now downloaded the latest version.

When adding cards, sometimes it happens that the cards are not added in order. This is considered a serious bug. If you test it, you may see the problem recur from time to time.


I found the cause of the bug.

When creating a new card, the card with Due number 0 is created as shown in the picture above, so even if the cards are set to appear in the order they are added in the custom study study, the card with Due number 0 appears in an odd order.

In conclusion, when adding a new card, Due should not be added as New #0.

I hope to test it once and let you know the result.

This is a bug that must be fixed.

For reference, I do not use addon, I use beta9 version of V2 scheduler.

The second thing I’d like to suggest is that the images on the card appear too small in the browser.

If you click the image and click the button on the far right, it will be the original size, but if you select another card, it will be reduced again.

I check the image on the front of the card in the browser and write the answer on the back of the card, but I feel inconvenient because the image is too small.

What I would like to suggest is, could you put a feature in the browser to fix the image to its original size?

I’m not sure having them at full size by default is best, since it’s hard for the program to know the right scale for each image and it’s much harder to see the fields if there’s a big image filling up the screen.


Thank you for the report, a fix will be in the next build.

Re release date, please see the top post.

@hengiesel is most qualified to answer this one.

Did you download/update any add-ons since you started Anki? If not, an add-on is probably using Anki’s HTTP client.

Short answer: Use Cmd/Ctrl+Shift+T.
Long answer: Normally (in the browser) tab focuses each element on the site that can receive input. This includes all visual elements, and includes buttons. In the Anki editor, it only focuses fields, but skips the editor buttons. The reason the tag section is skipped, is that there’s no good focus target available. Maybe what you’d expect is a new open tag to be focused, however the visual element for this new tag is only created when you click the tag icon, or click the space to the right of the last tag. Before clicking it, it doesn’t exist, so it cannot be focused.

You can also double-click images, to restore their original size (we could add this to the tooltip).

I think this is perhaps a new bug in recent betas:

On Ubuntu when I activate the tag line, no cursor shows up, nor does the tag line show letters as I type. The only indication that anything is happening is the popup that appears after typing which allows me to choose between existing tags.

I’m using this version (beta 9):

Version 2.1.50 (4515c41d)
Python 3.9.10 Qt 5.15.2 PyQt 5.15.5
1 Like

Could you provide a screenshort? Have you made sure that add-ons are disabled?

You can make the original image size by double-clicking, but if you select a different card, it will appear reduced again.

It would be good if the original image and small image could be changed so that the user can fix it as desired.

Specifically, if you double-click to create the original image size, it is automatically applied to other cards.

I don’t know if this is the place to make suggestions. If no, please, tell me @dae . But I would recommend dividing Cloze bottom in two:

  1. New cloze (CTRL + SHIFT + C)
  2. Same cloze (CTRL + SHIFT + ALT + C)

And make it a litlle bigger ansd more intuitive

I know that you are in a hard work now. Thank you for that.

1 Like

Not that I remember definitely didn’t update or install any in that session. Hasn’t occurred again, but I’ll keep an eye on it.