Anki 2.1.50 Beta 3-5

Anki 2.1.50 (beta 5) on Windows 10:

If I go to the Browser > View > Toggle Full Screen, all of the top buttons (Edit, View, Notes, Cards, Go, Help) become completely unresponsive until I exit full-screen mode.

You are exactly right. Currently, if you use ctrl + scroll wheel, it is changed to a too small size.

The anki zoom addon has just the right sensitivity, and I agree with it because a lot of people use it.

Also, the keyboard shortcut function of Anki 2.1.50 beta zoom is not good. (You couldn’t zoom in/out with ctrl ± keyboard shortcuts.)

If it is not possible because of the existing shortcut key, why not set it as a shift± shortcut key?

Finally, Anki 2.1.50 beta doesn’t see the zoom ratio. (Anki zoom addon shows zoom ratio in bottom left corner.)
The zoom ratio increases the user’s intuition.

There is an additional feature I would like to suggest.

When a button is pressed, I wish there was a notification showing which button was pressed.

There are many good add-ons that help with this function, but I think this should be inserted as a basic function.

Is it a reflectable function?

베타5버전에서 추가적인 2가지 문제를 발견했다. (anki-2.1.50+beta5_3564ece6-windows-qt6)

  1. 다크모드로 설정하고, 안키를 재시작하지않으면 상단의 메뉴들이 하얗게 보인다.
    아래와 같이 해당 버그가 발생하는 그림을 첨부하겠다.

  1. In the dark mode, press f11 to set it to full screen mode and study the card.
    There is blinking on the first and second cards.
1 Like

Apologies, I should’ve edited instead of deleted, I was having more than one issue, one of which was related to using AnkiConnect to send cards from Emacs to Anki, this was resolved with a restart of both Anki and Emacs and have isolated to be Emacs-related.

The only issue I am certain of now is that trying to open the AnkiConnect addon settings results in this traceback.

Anki 2.1.50 (3564ece6) Python 3.9.10 Qt 6.2.2 PyQt 6.2.2
Platform: Linux
Flags: frz=True ao=True sv=3
Add-ons, last update check: 2022-02-28 15:17:08

Caught exception:
Traceback (most recent call last):
  File "aqt.addons", line 951, in onConfig
  File "aqt.addons", line 1509, in __init__
  File "aqt.addons", line 1534, in updateHelp
  File "aqt.addons", line 631, in addonConfigHelp
  File "markdown.core", line 386, in markdown
  File "markdown.core", line 96, in __init__
  File "markdown.core", line 123, in registerExtensions
  File "markdown.core", line 162, in build_extension
  File "importlib", line 127, in import_module
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 984, in _find_and_load_unlocked
ModuleNotFoundError: No module named 'md_in_html'

@Rumo I’m a bit concerned by the number of issues Qt’s full screen option has on Windows. Is this something we could selectively enable for only particular GL drivers? Or maybe we need to be adding a “(buggy)” label to the menu item?

For now, the goal is to add support for zooming, not to implement every feature of the add-on. I will keep an eye on demand for other features, and they may be added in the future if demand is high enough.

Thanks, a fix will be in the next beta.

Makes sense. Maybe we can disable the action and add a tooltip “not supported for your video driver”.

2 Likes

Thanks for adding a fullscreen toggle. Could options be added to hide all the titlebars like No Distractions Full Screen?

i’m using an NVIDIA® GeForce® RTX 3050 (4GB GDDR6). Doesn’t make senses that’s not working, but this problem is not too much and does not disturb the use of the application. Maybe disabling is a better option for now?

Probably not in the short term; it looks like the full screen option will be disabled on Windows due to compatibility issues, and I don’t want this to hold up a release.

A post was merged into an existing topic: Simple but very useful change (SHOW ANSWER WITH NUMBER BUTTONS)

On 2.1.50beta5 qt5 I’m having a very difficult time putting tags in the editor. I can type one letter and then it freezes and I have to wait a few seconds before more letters appear. It’s happening without any addons and very consistently (i.e. every time)

I can’t seem to reproduce this - after entering a single letter, the tags in your collection pop up in under a second for me, and I don’t notice any lag if typing multiple characters. This is in both Qt5 and Qt6. Do you get the same behaviour with both? Does changing your video driver in the Qt5 build make a difference?

I had the same problem with previous betas (beta 3 I think) while using the AnKing deck that contains hundreds of tags (if not thousands)

Now running beta5 Qt6 it is normal but I noticed that the Add Tag button does not work

As a result of testing version 50 (beta 5) compared to version 49,

I’ve found that pressing the ADD, EDIT button causes the corresponding window to load slower.

Beta 5 version loads more slowly.

Please check once.

thank you.

I have small suggestion/annoyance (probably not specific to the beta(s)):

Is it possible to remove the automatic <br> tag that is added after a Mathjax Block.
I usually add some math blocks at the end of backside, and the automatic <br> tag adds unwanted blank space. Unless there is something I’m overlooking, I’m not sure why it is implemented.

It’s certainly not the preferred behavior. When it comes to the editing behavior, fixes are sometimes much more difficult than one would think.

As a workaround, you can insert a single letter, and then delete that single letter again. This will leave you with no newline at the end of the field.

1 Like

I have problem with scaling and font size that I described here.

Once a stable release comes out, please post any comments about it in a separate thread, and please avoid creating multiple posts about the same topic.