After updating - Error message appears when syncing


I have been using a not so old version of anki both (I’d say 1 year maximum) on my phone and on my laptop up to today and since I kept receiving prompts to update my software which i had been ignoring, I finally decided to give in and clicked on the update button (desktop version)

the new version of the software on my computer after the update shows in dark mode now for some reason (I don’t use a single add-on… Ok problem solved I saw that it’s because it follows the settings in the system), but the main problem is that since the update I get an error message everytime I sync, but also when I’m not syncing (probably caused by automatic syncing) which showed lines of code I don’t understand and telling me that if the problem persists I should go in Tools → check database which I did and only prompts more similar error messages (A)
Yet the changes (new cards created) I make on my anki on my computer software are visible in ankiweb so it’s working

the main problem is that now I can’t sync my decks as well on my phone and I’m being told an error message (B) :
blablabla we can’t update your library either my SD card is mounted read-only or that there isn’t enough space anymore
I have plenty of space and I haven’t touched anything about my SD (I don’t know how to change my SD to read-only or not)

I tried to:
uninstall my anki app on my phone and reinstall the latest version of ankidroid (through apk evozi because I don’t have google play with my huawei… I live in China)it didn’t work because of native code not supported by my ABIs
I download an app to see what’s my CPU architecture and after learning it’s armeabi-v7a, I download the latest version of anki available on apk mirror (2.15.6) and this version of ankidroid installs on my phone and I log in to ankiweb successfully, it starts syncing but starts at 27000~KB for some reason but anyways shortly after I’m being told the same message than before (SD card read-only or not enough storage space)
I decide to manually erase all the files related to Anki in my phone, uninstall the app, reinstall and try again but I eventually get to the same point (syncing starts at 27000KB and laters tell me that I have pbs with my SD)
I tried to modify the ankidroid directory in the advanced settings of the app but nothing is accepted but the default path
install a sort of recent version (2.14) I get a different error message (C)
“your anki client doesn;t support the new timezone handling yet. Please ensure your Anki is up to date”
install a really old (2.10) version of the app - I get the same (C) error message

I don’t know what to do… I haven’t played with settings or anything I was just creating a few cards as usual this morning and everything became complicated and unusable…

Can anybody help ?
Thanks in advance and sorry for this long message


Problem fixed after

  1. forcing syncing in one direction from my anki (desktop) to ankiweb (overwriting ankiwe in the process)
  2. then exporting manually all my decks from my anki (desktop) in .colpkg files format into a usb key
  3. importing those files manually from this USB key into my phone (using the import function of the anki droid app)
  4. then choosing to force syncing in one direction in the settings of the phone app
  5. then when starting to sync on my phone I chose to use the database of my ankidroid to overwrite my ankiweb’s… I don’t understand why it did download a lot in the process (and not only upload)…

now syncing resumed normally in both ways
I am asked again to update my scheduler to the V2 scheduler version… which is what started that whole mess
I think I’m going to pass :)

Hope this thread helps somebody !

Good luck with your problems

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.