Anki Forums

Adding Cards: Disable Prompt "Close and Lose Current Input"

How can I disable the prompt: “Close and lose current input?” that pops up while I am in the middle of adding a card?

This prompt will usually pop up when I am working on a card for more than 5 minutes. I have tried disabling the auto-sync feature, and this is not what seems to be causing the prompt to pop up.

The reason I want to disable this feature is because when I am typing quickly, the space bar forces me to “select yes” and I unknowingly lose all of my work. It is incredibly frustrating.

I am at a loss as to what other options I could change.

Thank you for your help.

i think you’re using anki < 2.1.16

The reason I want to disable this feature is because when I am typing quickly, the space bar forces me to “select yes” and I unknowingly lose all of my work. It is incredibly frustrating.

in anki version newer than 2.1.15, this dialog’s default answer is no. meaning if you accidentally press space/enter, anki chooses no as the answer and you won’t lose your input.

2 Likes

As for why it’s popping up, I can’t think of any reason other than you accidentally hitting the Esc key, or some behaviour of an add-on you have installed.