About the file import problem

I usually use it on ipad with marginnote3, but since some time ago, there is a card group in marginnote that cannot be imported to anki, it shows as (foundation._GenericObjCError error0.), try other bigger card groups in marginnote are importable. I tried to send the file to the iphone side to import, and it worked, but I found that the cards were not updated, and the cards with duplicate titles would automatically choose to cancel the import. I don’t know if it’s iPhone related, as I’ve always updated the card information when using it on my ipad. I think it should automatically select replace or give the option to “replace”, “skip”, “keep both”. I would like to have these two questions answered, thanks!

Please go into Preferences>Editing - is the the new .apkg importer enabled?

  • If it isn’t, does turning it on help?
  • If it’s already enabled, could you send me a sample .apkg file that won’t import, so I can try to reproduce the problem?

Thank you very much, the card sets can be imported after turning on this option. But the card sets still don’t update, they are skipped. I am very sorry, because this was not the case before, so I thought there was some version problem. After checking, I see that “A drop-down box in the import screen allows you to change this behaviour”, but I don’t know where the box is, and it doesn’t seem to show up on the import page. So I don’t think I’ve clicked it either. I checked the settings and there doesn’t seem to be a similar option. I’m very sorry, but I have no useful information beyond this query, and I would appreciate your answer.

A message should pop up at the end of the import. Does it say “some notes could not be imported because the notetype has changed”? If that’s the case, Anki will not be able to import the updates unless you modify the notetype to identically match the fields/cards that are in the .apkg file. This is something we’d like to improve on in the future.

I’m so sorry, maybe because I switched languages, I didn’t pay attention to this message at all, because that wasn’t the case before and I thought it was a setting or version change. I apologize for my carelessness and anxiety.
I was using the exact same notetype as before, but a lot of new notetype versions were created when I imported it, which I couldn’t understand. After I changed the notetype of the original card group to the notetype of the new card, I tried to import it again and it showed “invalid input: 443 missing from archive”, I hope you can help me.

That indicates the program that created the .apkg file declared a media file was included, but didn’t actually include it. If the apkg was created with marginnote, please report this bug to them.

1 Like