A network error occurred - please help!

I downloaded Anki for 64 bit windows (2.1.35-standard) as that is the version I require. Upon attempting to sync I received an error stating that ‘A network error occurred.
Error details: error sending request for url (): error trying to connect:tcp connect error: No connection could be made because the target machine actively refused it. (os error 10061)’

I did upload a screenshot here but it has been added a text??

Can anyone offer any advice please?

I installed Anki desktop for a teacher, so it’s obviously a school. Sophos website filtering is used in school but the anki website is not blocked by the schools web filtering. If anyone knows what causes this error or can suggest any web addresses that can be added to the schools web filter, that would be very helpful.

Thanks in advance!

Sync error

That error message is typically caused by antivirus or firewalls, so I’d suggest double-checking any filtering/proxying that is on the machine/network.

I got the same problem as yours and still not figure it out.

Thanks dae, we do have web filtering, antivirus and a firewall. Do you know if there is a ‘whitelist’ of sites that we can add to our web filtering please? The anki domian has been whitelisted in our web filtering, but it could be that the sync’ing uses a different domain??

It’s frustrating, isn’t it!

Ive got it done by just turning my PCs proxy server off. Why don`t you give it a try?

1 Like

I work in a large school with a firewall and a proxy server, which I cannot turn off unfortunately. I will need to found out exactly what web addresses, ports or firewall rules etc Anki uses.

Try searching for ‘firewall’ in the manual.

Ok, thanks I will try that.

this may solve the issue:
open internet options window (one way is searching it in start)
then go to the connection tab and click on LAN setting and match your setting with the image below



thank you so much! your solution solves my problem well.

1 Like

I had this same problem. I solved it by doing the following:

Gave full permission to everything on that list

I’m a bit puzzled as to why that helps in this case, but thanks for taking the time to post your solution.

Ignore my previous post. This wasn’t due to those permissions I posted. Anki works perfectly right up until the point where I start a Freedom (www.freedom.to) session. The issue was resolved after I restarted my PC.
I discovered that I got the following error:


The error only appears when I have a Freedom session running.
If I end the Freedom session via Task Manager, I then get the following error from Anki:


Which doesn’t go away until I restart my PC. The problem then begins again once I start a new Freedom session. I emailed Freedom support team to ask for a solution. This issue doesn’t occur on AnkiDroid, even though the exact same Freedom session is running on my phone.

Disabling firewalls and antiviruses does nothing.


I found this “Non-proxy mode” in the Freedom settings and enabled it to see what happens:

So it appears as though my problem has been resolved. I’m now able to use Anki during a Freedom session. So I suggest other Freedom users to enable this option in their Freedom settings if they want to use Anki.

It’s just weird how this Freedom “proxy” remains even if I force-close Freedom from Task Manager and how it doesn’t go away until I restart my PC.


Thank you very much. Your solution solved my same problem very well.