[5145] Failed to execute script runanki

I’ve been using Anki almost every day for years now with no problems. I’m running the latest version of Ubuntu, and for no apparent reason (no update or anything else has taken place), I realised this morning that Anki will not execute; I press on the icon but nothing happens. To diagnose the problem, I tried running it from the Ubuntu terminal, and got the following error:

[5145] Failed to execute script runanki

I have even tried uninstalling and reinstalling it, but that makes no difference. I really need to access these cards every day in order to stay on top of my studies. I have done research on DuckDuckGo and elsewhere on this forum, but all the solutions are Windows-specific, and don’t help anyway. I’ve tried restarting my machine multiple times.

I’ve uninstalled and reinstalled from the tar.gz instead of from the Ubuntu repository. Installation works fine, but when I run the terminal command anki, I get this error:

Bus error (core dumped)


The problem, for no apparent reason, now appears to have gone away. I’m not alone in experiencing this problem inexplicably only for it to go away after a day or two, which suggests an underlying issue that needs to be resolved. Anki is a serious piece of software on which possibly millions of people rely; it cannot be allowed to exhibit such egregious bugs.

I’d write directly on Github to the priestly caste who develop Anki requesting this is examined, but they’d only direct me back here.