Anki Forums

Failed to execute script runanki

Hello. Thank you in advance for your help and consideration.

I updated anki and was using it without any issues. Today I got a lovely message from my computer. The message was “Fatal error detected Failed to execute script runanki”. I uninstalled and tried installing a few older versions. That didn’t help. I googled the issue and saw that other people have had the same issue in the past. I followed the initial advice given to those people.

I got a few screenshots out of that.

Any help would be greatly appreciated.

Update:
I tried starting up my computer this morning and running Anki and everything seems to be working fine as if there never was a problem. I have no idea what happened but it seems to be working fine.

It’s an issue caused by a Windows update, and completing the update + restarting once or twice seems to fix it.

1 Like

Thank you very much.

Hi. SO yesterday I tried to open anki on my windows 10 laptop but it says ‘failed to execute script runanki’. I checked the posts similar to mine and followed the instructions such as downloading all available updates for windows 10 and restarting, but the problem still persists.
I copied and pasted the command prompt thingy below:

Microsoft Windows [Version 10.0.19043.1165]
(c) Microsoft Corporation. All rights reserved.

C:\Users\hp>cd \program files\anki & anki-console
[17900] PyInstaller Bootloader 3.x
[17900] LOADER: executable is C:\Program Files\Anki\anki-console.exe
[17900] LOADER: homepath is C:\Program Files\Anki
[17900] LOADER: _MEIPASS2 is NULL
[17900] LOADER: archivename is C:\Program Files\Anki\anki-console.exe
[17900] LOADER: C:\Program Files\Anki\anki-console.exe contains a digital signature
[17900] LOADER: No need to extract files to run; setting extractionpath to homepath
[17900] LOADER: SetDllDirectory(C:\Program Files\Anki)
[17900] LOADER: Already in the child - running user’s code.
[17900] LOADER: Python library: C:\Program Files\Anki\python38.dll
[17900] LOADER: Loaded functions from Python library.
[17900] LOADER: Manipulating environment (sys.path, sys.prefix)
[17900] LOADER: sys.prefix is C:\Program Files\Anki
[17900] LOADER: Pre-init sys.path is C:\Program Files\Anki\base_library.zip;C:\Program Files\Anki
[17900] LOADER: Setting runtime options
[17900] LOADER: Initializing python
[17900] LOADER: Overriding Python’s sys.path
[17900] LOADER: Post-init sys.path is C:\Program Files\Anki\base_library.zip;C:\Program Files\Anki
[17900] LOADER: Setting sys.argv
[17900] LOADER: setting sys.MEIPASS
[17900] LOADER: importing modules from CArchive
[17900] LOADER: extracted struct
[17900] LOADER: callfunction returned…
[17900] LOADER: extracted pyimod01_os_path
[17900] LOADER: callfunction returned…
[17900] LOADER: extracted pyimod02_archive
[17900] LOADER: callfunction returned…
[17900] LOADER: extracted pyimod03_importers
[17900] LOADER: callfunction returned…
[17900] LOADER: Installing PYZ archive with Python modules.
[17900] LOADER: PYZ archive: PYZ-00.pyz
[17900] LOADER: Running pyiboot01_bootstrap.py
[17900] LOADER: Running pyi_rth_win32comgenpy.py
[17900] LOADER: Running pyi_rth_multiprocessing.py
[17900] LOADER: Running pyi_rth_certifi.py
[17900] LOADER: Running pyi_rth_pyqt5.py
[17900] LOADER: Running pyi_rth_pkgres.py
[17900] LOADER: Running pyi_rth_pyqt5webengine.py
[17900] LOADER: Running runanki.py
Traceback (most recent call last):
File “runanki.py”, line 3, in
File “C:\release\lib\site-packages\pyinstaller-4.0.dev0-py3.8.egg\PyInstaller\loader\pyimod03_importers.py”, line 497, in exec_module
File "aqt_init
.py", line 20, in
File “C:\release\lib\site-packages\pyinstaller-4.0.dev0-py3.8.egg\PyInstaller\loader\pyimod03_importers.py”, line 497, in exec_module
File “aqt\qt.py”, line 18, in
ImportError: DLL load failed while importing QtWebEngineWidgets: The specified module could not be found.
[17900] Failed to execute script runanki
[17900] LOADER: OK.
[17900] LOADER: Manually flushing stdout and stderr
[17900] LOADER: Cleaning up Python interpreter.

C:\Program Files\Anki>

Please help me fix this issue, I have my board exams coming up in around 12 days.
Thanks!!

So it suddenly stopped working? Anki does not update itself automatically, so when things suddenly break, it tends to be caused by external factors like a Windows update or antivirus programs. If reinstalling Anki does not help, you may need to start trying to roll back updates or look into the other software running on your machine.

I didn’t understand what you said completely, sorry! Can you clarify?

Just try to install Anki again.

Update again: anki finally opened, but its the 2.1.47 version. i had downloaded an optional windows update that kept popping up, and prior to that i had uninstalled my previous anki and then downloaded said version, and after downloading the windows update i restarted my laptop.
Anyways its working now. But still I want to know what had happened to my previous version of anki. Thanks!!

Update: Its again showing the same message-failed to execute script runanki. What do i do?

Update: I formatted my laptop and reinstalled anki again but it still shows the same message.

I was having this issue, then I ran Anki as admin and it opened right up