2nd PC won't play audio generated from Azure, but 1st does

So I am having a strange problem. On PC#1 (Windows 10, anki 2.1.35) I used Awesome TTS to record audio to cards in a certain deck, by generating an API and recording audio to the card via Azure.

It worked great and still works great. I hit sync and then opened Anki on my iOS app. It works great, the sound plays exactly as it should.

Then, I hit sync and later in the day installed Anki on PC#2 (Windows 10, same Anki version) and synced again and pulled up my deck. The audio files don’t make any sound. Oddly, if I view the sound mixer in windows, the volume bars jump up and down as if its making a sound, but it doesn’t actually play any sound. I checked the media collection folder and the files are indeed there. And, if I open the sound files regularly through windows media player or VLC or whatever the audio plays fine. I also tried attaching several other audio files from my PC and adding them to the Anki deck and they play fine.

So for some reason, Anki on PC#2 will not play any audio files created by Azure, recorded or streamed. Even if I click the preview function on the audio when I’m adding a new card (which I assume does a live stream using an API call to Azure, instead of a recording), the volume bar jumps but no actual sound comes out. However, if I use another service like the SpanishDict audio option, it plays fine.

So I have a situation where Anki doesn’t make any sound via Azure generated audio files on PC#2, but windows plays it fine, and PC#1 and the iOS device play it fine.

Does anyone have any idea why this may be?

That’s odd. If you drag one of the files onto mpv.exe in the Anki program folder, do they play?

Well, I tried and the mpv application loads and the progress bar progresses through what should be the length of the audio clip, but no sound actually comes out of the speakers. However, if I drag any other mp3 I have on my computer, the mpv application loads and plays the audio as expected.

It seems as if it’s something unique to those mp3 files, and I’m afraid I’m not sure what could be causing it if the audio is showing as playing in the volume control screen. @kelciour I don’t suppose you have any ideas?

It’s really strange.

Since you’re on Anki 2.1.35 with mpv.com lying around, I can suggest to try to play the same audio file from the command prompt window using mpv 123.mp3 or mpv -v 123.mp3. Maybe the output will contain something useful.

Demo Video


Second option is to try to play the same audio file with the latest mpv version from https://sourceforge.net/projects/mpv-player-windows/files/64bit/

Another option is to install Anki 2.1.35-alternate to try mplayer instead of mpv.


@kelciour Many thanks for the help! And you too, dae.

So I tried playing the same audio file using mpv and the command prompt per your instructions, and it loaded the file and seemed to go through without error but no sound came out. Then, I downloaded the newest version of mpv per your instructions, the 20201206 release as of the time of this writing, and tested it with the same audio file and it played just fine. The only difference in screen output between the older version of mpv and the newer one, is on the line A: on the older version it ends in 87% and on the newer version it ends in 81%. I have no idea what that means, but what I do know is that it worked and I heard the audio.

So, I don’t know if this is the recommended method, but I copied the newer mpv version files into the Anki directory, and now Anki works as it should as far as I can tell, and it plays the audio from all of my clips.

So I very much appreciate your help and the time you both put into answering my question!

1 Like