Sound not working on windows anki app

I am using the “Core 2k/6k Optimized Japanese Vocabulary” deck, and some other decks that use sound, that plays mp3 sounds and it doesn’t work. However, I can get the sound to work on my iPhone version of Anki and on AnkiWeb.

I’ve tried restarting my computer, just restarting Anki, disabled every Add-on. I was using version 2.1.49 but upgraded to 2.1.53 Qt6, but neither work.
I’m also using a Windows 10 Home Edition.

Any help would be appreciated.

If you drag an mp3 file onto mpv.exe in the Anki program files folder, does it play? Does Tools>Check Media report missing media files?

1 Like

Dragging a .mp3 file onto mpv.exe in the ‘audio’ folder worked, pulled up in a mpv player or something.

The Check Media report only lists .jpg files missing because I didn’t download the image extension to the deck I downloaded and uploaded.
However, the sound for the cards works for AnkiWeb and my iPhone app so I know the sound works, just not on my windows app for Anki.

-edit- Want to add that sound doesn’t work for my other decks either on the Windows app for Anki, it’s not isolated to just that one deck I initially brought up.
Also, I pulled up the anki app for my MacBook Pro and the sound worked, so this just seems like a Windows OS issue for me.

Reposting this, and deleted other comment, because I wasn’t sure if I replied to your comment directly.

-edit #2- Also want to bring up that sound does work on my Windows computer, thought I’d bring that up. So this sound issue is isolated to just the Anki app on my Windows computer.

You could try installing mplayer. To do so, download it, then put it in the directory where the mpv.exe file is, then rename the latter into anything else (maybe mpv.old.exe so you will be able to find it again). Then just launch Anki and see if it works.

Can you explain a little more about the product before I download something from an unsecure, ancient-looking website?

Not sure which version I would need to download either, there is a wall of text and links.

Thank you for the recommendation though, I’m just overly cautious about downloads; I usually wouldn’t follow an embedded link usually.

Maybe this will help: Zzz (legacy) No Sound Fix (libmpv) - AnkiWeb

Well, I don’t know much about mplayer besides the fact that it basically serves the same purposes as mpv (mpv is a fork of a fork of mplayer).

If you want a third-party figure of authority, I would recommend going on its wikipedia page, which indicates both want it does and what is its official website (which is the link I sent you).

Be aware that these two things are absolutely not necessarily correlated. I agree their website is quite ugly, but at the same time there is no reason to believe it’s insecure (its static webpage are, indeed, delivered in plain text, but the source code is delivered securely), but virus makers can also pay web designers…

Also, they provide you full source code so if you really don’t trust them you could built it yourself.

Just reading the text from the beginning works… in the end, they redirect you to this page, which offers you both the 32 bits and 64 bits version.

That’s very good, but it’s not really compatible with how Windows works… for instance, on my computer, to install mplayer I would just have to add mplayer to my config file and it would automatically download it from a trusted source, then build it and provide it in the right place… it’s the power of package managers.

Didn’t work. Installed it and restarted Anki.

Sorry for late reply, wasn’t able to get on during the weekend.

Also, I tested both my monitors speaker as well as my headphones that I usually use; They both work for normal computer use but don’t with Anki app. Thought I’d bring it up because I always use headphones, so I tried out my monitor speakers too, no luck.

I’m afraid I’m not sure what the problem might be. If you’re wary of downloading mplayer from a website, you may be able to extract it from the Anki program folder of anki-2.1.35-alternate. Removing mpv.exe and putting mplayer in that folder should cause Anki to use it instead.

(I suggest you downgrade first before installing 2.1.35-alternate, and then confirm sound works in that version before you attempt to copy files about)

Ahh, so mplayer is an officially “endorsed” fix to this issue maybe?

I’ll try it out from that website if you are saying to try it.

Still slightly confused since the site seems a little technical to me still, but thanks for the redirect page.

I have a 64-bit Windows OS so which of the three options do I choose? Release Binaries, Debug Binaries, or Source Code?
Uhh, I assume it may be the Release Binaries since it is the first listed but I have no idea.

Trying this out since dae mentioned maybe trying it out.

Yes, maybe it wasn’t clear (I took it for granted, but it’s actually not for most users :stuck_out_tongue:). mplayer is “officially” supported, in the sense that Anki will look for mpv, and if it can’t find it it will fall back on mplayer (which is why you need to rename mpv.exe, so Anki won’t find it). This is not a “dirty” hack, simply an alternative way of playing sound supported by Anki in cases where mpv doesn’t quite work.

Among all these options, you need to choose “Release Binaries”. Debug binaries are similar but also include some stuff useful when doing very low-level debugging — which isn’t your case, I assume. Release binaries may also include some optimisations that are left out from debug binaries, so as a user it’s always more convenient to go for the release binaries. Source code is the actual program the developer wrote You would need to compile it first to be able to use it. The release binaries are simply the result of that compilation step, which are provided as a convenience (so that end users like you don’t have to hassle with the compilation step).

I had the same problem and solved it by changing the device that plays the sound.

I have a laptop and an additional monitor and I had problems with the sound when the sound was to be played from the monitor but when changing to a laptop, everything works normally …

Very strange but it works;)

PS. This problem occurred after a fresh installation of windows 11.

1 Like