Audio stopped playing after updating ANKI for Windows

Hello everybody,

I have a weird problem, just updated Anki and all audio in my huge deck does not play audio files at all! I tried to make a new profile and import the previously exported deck from the older version I used before and it still does not play.

It seems that media files are there, so I do not know what to do?

Thanks for any suggestion,

P.S.: I just used the Check Media Tool after synchronization (the program asked me to upload everything) and it shows a bunch of missing and unused files…

Is there any way to fix this?
P.P.S: Sorry for posting similar as on the Reddit page, but I am quite nervous about losing all (thousands) of my personally recorded voice files, I already re-recorded some before when there was a similar problem, but at that time it was only a small portion of cards, now it is just all of them.

  • Maybe replace mpv.exe and d3dcompiler_43.dll in the Anki’s installation folder with the latest version from

  • Maybe locate the mp3 file in the folder and drag-and-drop it over mpv.exe in the Anki’s installation folder (to check that mpv can play the mp3 file just fine by itself)

  • Maybe temporarily enable mpv logging using this code in the debug console, review a card, click once or twice on the audio replay button, wait a few seconds and look at the “mpv.log.txt” file on your desktop (maybe the last lines will contain some helpful information why it doesn’t work).

    import os
    from aqt.sound import mpvManager
    path = os.path.expanduser("~/Desktop/mpv.log.txt")
    mpvManager.set_property("log-file", path)

    The last lines should look something like this.

    [3269.419][d][cplayer] Run command: loadfile, flags=64, args=[url="C:\\Users\\...\\AppData\\Roaming\\Anki2\\User 1\\\\audio.mp3", flags="replace", options="pause=no"]
    [3269.463][v][cplayer] starting audio playback
    [3279.762][v][cplayer] finished playback, success (reason 0)

Hi, thanks for the reply. I could not find these files in the Anki installation folder (or could not really find that folder).

I found the media files folder, there were also some backup col files, I just for security copied them somewhere.

Where should be the installation folder? There is only some QtWebengine folder in the Anki folder under AppData - Local.

It should be %LOCALAPPDATA%\Programs\Anki, i.e. C:\Users\%USERNAME%\AppData\Local\Programs\Anki. If it’s not there, maybe check the Properties window of the shortcut icon.

I tried replacing the files, no change.

SOLVED. It was caused by a stupid thing - I had the laptop connected to a TV and the audio was switched to the TV (which was off at the time). However, the previously problematic cards, which I partially re-recorded before are still not playing, though the files might be there, I will check these, too.

So thanks to you, I found the solution to this problem, too. For some reason (I guess synchronization) they are not located in that profile, but are located in another profile, which is under another folder. I can copied one and it worked. I will do some slow backup and copy now. Thanks a million!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.