2.1.54 Bug: Audio files not attaching correctly

After updating to 2.1.54 (b6a7760c), I am no longer able to attach audio files as normal.

When I use the “attach audio” command and click the file to attach it, the “[sound:FILENAME]” thing does not actually show up in the field I have tried to attach the audio to.

If I then add the card to the deck and then run the card, there is no audio.

The only way I have found to actually get the audio file to attach is to click “attach audio,” click the file, and then click “close” to close the card without adding it to the deck. When I get the prompt saying “Close and lose current input?” I click “no” and then the file attaches to the card.

I ran all seven steps listed in the FAQ to try to fix this myself (restarting, shutting down all addons, etc) but it did not work.

My system: Mac OS Monterey 12.4, Intel

Thank you.

1 Like

Seems to work for me. Have you rule out add-ons?

Yes, I followed all seven of the troubleshooting steps in the FAQ, including disabling the add-ons and it still does not work.

I tried with the Qt6 version on a Mac, and still can’t reproduce it. Either clicking on the paperclip or triggering it with f3, double-clicking on a sound, and then either clicking on Add or pressing cmd+return, the sound file is correctly attached to the card when I locate it in the browse screen. Are you doing something different?

Thank you for trying to reproduce it. I am attaching the sound file the same way as you describe. This is the first time I’ve ever had a problem attaching a sound file since I began using anki in 2008.

I’ll keep an eye out for other reports, and perhaps we can find some pattern to when it occurs.