Windows update broke Anki

For me it worked. I uninstalled Anki and donwloaded the last 32 bits version. It had a problem with synchronization but I just checked the database so it worked.

Thank you guys.

I change the shortcut
Target: “C:\Program Files\Anki\anki-console.exe”.
It work.

Last line of console is
“mpv too old for key rebinding”

1 Like

I had the same problem and did exactly the same thing you did and it worked here!

I’ve been using anki for months, and a few days ago when I tried to open the app, the message " Do you want to allow this app to make changes to your device?" appeared and no matter if I clicked yes or no, nothing happens.
I already tried reinstalling the app, run as an administrator, open while holding shift, tried the latest stable version, but it’s the same result, nothing happens and the program won’t open.

Thank you

1 Like

See Windows update broke Anki
This may be related.

It worked! Thank you very much.

I have the same problem.

Any adventurous users who would like to help me get to the bottom of it, please see Standard build won't start

Good morning, I removed ANKI 2.1.26 and installed it again. Do not open. I removed it again and installed 2.1.29 also it won’t open.
Important, erm any version if I activate anki-console.exe inside the folder of ANKI it runs on the black screen of windows w opens. It works normally, but if it closes it does not open. For the ind = training we have the system is in trouble and with no expected return. You have some information about that. I have installed ANKI on other machines, and the problem is the same. On Android phone it works 100%. I look forward to good news.

Please see Windows update broke Anki

Prezado, grato pela informação. De fato a versão de 32 bits está funcionando. A Microsoft soltou uma atualização recente e deve ter sido o causador dos problemas do ANKI 64 bits. Grato pela parceria. Se cuidem por favor.

I’d be great if people could try the latest 64 bit beta version and confirm if it works for them or not. It’s expected to be released as stable in a few days, so should be safe to use.

Pessoal, a solução deste problema foi a instalação da opção 32 bits da versão 2.1.29.

Alguém poderia informar se o problema foi definitivamente corrigido na versão 2.1.30, onde poderemos instalar a opção 64 bits dessa versão?

The 64 bit version of 2.1.30 should work

1 Like

Tried this solution but didn’t work.
Running Windows 20H2.
Tried with both Anki 2.1.37 and 2.1.35 for 32 and 64 bits.

I can see in the Task Manager taht Anki.exe is opened when I click on it, but then after a few seconds it disappears and I don’t get to see any UI at all.

I have no antivirus or so installed.

In the Event Viewer I can see the following:

Faulting application name: anki.exe, version:, time stamp: 0x5d24a365
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x00000000
Faulting process id: 0x269c
Faulting application start time: 0x01d6da4729bc63ca
Faulting application path: C:\Program Files (x86)\Anki\anki.exe
Faulting module path: unknown
Report Id: 0758f64a-4e75-44d8-90f2-e3d593436bdb
Faulting package full name:
Faulting package-relative application ID:

Any clue what can be the issue and how to fix it?
I have been using Anki for 9 years now, it’s very annoying that I cannot open it…

Thanks beforehand

The best course of action is probably to run anki-console.exe.

I did that too. The text shown is the same that someone posted above.

It might be a long shot, but maybe

1 Like

Hi @kelciour , thanks for all the details!
I followed the steps one by one.

At the end, when I run the command

Same thing happens, I see the process Anki.exe starting in the task manager and then gone after a few secs.
If I look in the event viewer this time I can see python.exe failing:

Faulting application name: python.exe, version: 3.8.7150.1013, time stamp: 0x5fe0e34b
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000000000000
Faulting process id: 0x24bc
Faulting application start time: 0x01d6daab0ff334e3
Faulting application path: C:\Users\unarc\AppData\Local\Programs\Python\Python38\python.exe
Faulting module path: unknown
Report Id: f9eaa863-9b15-4712-90a9-80bae829744d
Faulting package full name:
Faulting package-relative application ID:

Although I see this error only when I try to run

I can normally use the rest of python apps and I can also run python.exe itself.

I’m not sure if my skills will be enough to help with it but I googled a bit and at the moment can suggest to

  • Uninstall Python 3.8, delete pyenv folder from C:\, then install Python 3.9.1 from and try to run Anki again using pre-built Python wheels.

  • Run the following command (or something similar) to print the full event log for the most recent crash or maybe it’ll be the same as in the event viewer and won’t reveal anything new.

    wevtutil qe application /rd:true /c:1 /format:text /q:"*[System[Provider[@Name='Application Error']]][EventData[Data='python.exe']]"

    Additionally, start Anki using the following command. It might provide some new information (if I get it right).

    \pyenv\scripts\python -X faulthandler -c "import aqt;"


    set PYTHONFAULTHANDLER=1 && \pyenv\scripts\python -c "import aqt;"

    Issue 29908: Inconsistent crashing with an access violation - Python tracker