Anki not opening; appears in task manager

I have been having this issue for 2 days now. After a recent Windows security update, Anki would not open. I know there are other forums that have addressed this same issue, but I have tried all of those suggestions. I have tried uninstalling, clean reinstall, running as administrator, running in compatibility mode, rolled back the security update, unplugged my extra monitors, changed the decimal/period for my date/time, tried beta versions. I rolled all the way back to the anki-2.1.35-windows-alternate.exe and it would work, but I really want to be using a more up-to-date version.

When I run the Anki console, I initially got:

Subsequently, the Anki console was showing this (without doing anything to actually fix the initial issue it was showing previously):


I am extremely frustrated. I have lost 2 days of making cards and I really can’t keep scouring the internet for a solution. Any help is appreciated. Thanks.

You didn’t mention – did you try both Qt5 and Qt6? Startup Issues - Anki Manual

Yes, I have tried both versions! I was trying to remember everything I tried. Missed that one.

1 Like

Please see Fails to start on Windows · Issue #2973 · ankitects/anki · GitHub

I will review this more later but it seems like the main solution there was unplugging external monitors. I have a desktop PC and can’t unplug all my monitors, but I did remove my second and third monitors.

I have figured it out. It seems that a windows security update was making it impossible to open anki. I went to Windows Updates > Update History > Uninstall updates > Uninstalled the most recent security update. BUT, you have to also turn off automatic updates as described here

I hope this helps anyone in the future (and serves as a reminder for me in case this happens again).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.