Windows 10 2.1.62 Qt6 - Blank Import Window

Hi everyone, I just installed Anki today and I cannot import decks on my desktop when I go File > Import or select the “Import File” at the bottom of the main window. It just opens a blank Import window.

I’ve tried the following based on my internet search:

  1. Restarting the computer
  2. Closing and relanching Anki Desktop
  3. Opening Anki with the Shift button pressed down to temporarily disable add-ons (Even though I didn’t install any)
  4. Use a simple text file with one card and a semicolon as the separator
  5. Saving the text file as UTF-8 csv with Libre Office for importing

None of these seems to work. I tried the Qt5 version and same results.

What can I do now? Everything else in the desktop seems to work (Add window, Browse Window, Stats Window, creating a deck, creating a card, etc). I have big text files with about 60-70 cards that I want to import rather than manually creating cards :frowning:

Another piece of information that might be handy is that I’m trying to import French/English cards to study French. But I feel like I would get error messages instead of a blank window with just the title in the top window bar.

Thank you!

Does the filename of the file you’re trying to import, or any of its parent folders, contain characters like spaces, or non-Latin text like accented characters?

I tested with a simple file called “TestCards.txt” in This PC > Documents and I still have the issue. No whitespace characters nor non-Latin characters were in the file name or folders.

I receive a blank window if I try to import the text file that was accidentally saved as UTF-16 with BOM.

Maybe try to import it after enabling Preferences > Editing > Legacy import/export handling.

Maybe upload the text file or MRE (“minimal, reproducible example”) on or somewhere else.

The next Anki version should show a pop-up when it encounters an error, instead of just a blank screen. In the mean time @zarinstar, please paste here what is shown in the console when you attempt to import that file.

Looks like a single parenthesis is the reason for such a major bug :open_mouth:

This PC>Documents is likely a friendly name for a longer path like c:\users\my user\documents. Are you able to provide us with the exact path? Do you use OneDrive or something like DropBox for your documents folder?

I honestly thought that was the path until I opened the folder in the powershell to get the real path.

So my original problem was when I was using files from C:\Users\Dar'ya\Dropbox\Languages\French where I work most of the time. I tried testing in C:\Users\Dar'ya\OneDrive\Documents as well with no success.

Could it be the apostrophe in my name? That’s how my legal name is spelled and it’s how I write it everywhere. Otherwise, it might be because I use Dropbox.

It was the apostrophe. Please try Release 2.1.64rc1 · ankitects/anki · GitHub

1 Like

That did the trick! I honestly thought my name wasn’t part of the path but the friendly names tricked me. If I had a nickel for each time my name caused trouble, I would be in early retirement! Thank you for your patience and your work!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.