MacOS Intel 24.06.2 - Blank Import Window

I am urgently needing help as i just purchased an anki deck for a test tommorow.
Everytime i try to import the file in various formats the import pop up is blank. I have even tried downloading it from the web and its still blank

Windows10?

Update to latest version and check addons Troubleshooting - Anki Manual

I’m using a macbook air and have downloaded the version of anki that is compatible with my most recent update.
I’ve tried all the trouble shooting steps but the import screen is still blank

Are you using an intel based chip?

What is the version of anki that you are using so i can update the title with the correct info (Anki → About Anki)

If yes, then this problem has been reported

1 Like

Yes i am using an intel core i5 chip and i am using version 24.06.2 version of anki

A fix for this is likely on the way, but since it is a newly introduced/reported issue, you might get working faster by rolling back to 24.04.x or 23.12.x. [Make sure you – File > Switch Profiles > Downgrade & Quit .]

See also –

The other time this has come up, it’s been an issue with special characters in the filename/path-name. This is many versions old now, and it looks like it was fixed back then, but if you’ve got special characters in your path, you might try fixing that.

1 Like

i tried the switch method and this hasn’t worked.

Which is “the switch method”?
Does that mean that you can’t get the “Switch Profiles” window to show so that you can “Downgrade”?
Or that you rolled back to an earlier version and it didn’t work? – Which version was it?

yes the one so that i can downgrade, i downgraded and there was still no change.
i am unsure how to roll back down to an easier version

Oh, I get it. Clicking “Downgrade & Quit” just gets your database ready for you to downgrade. You’ll still need to install the earlier version.

You can find the prior releases on GitHub – Releases · ankitects/anki · GitHub.

2 Likes

okay i’m going to try this now

which one should i download

Do you remember what version you upgraded from? Otherwise try the most recent release of 24.04… first.

hello, the advice given to me in this forum, worked for me. I had to download a previous version of anki, the link is above

1 Like