White flickering between cards after updating past 2.1.41

Hi, I recently updated my Anki Desktop (2.1.35, on a Mojave Mac) to the last version available currently (2.1.44), and I started noticing frequent split-second white splashes when I press “show answer” or any of the ease buttons (i.e. when anki loads something new to show).

I tried to disable all my addons (and also to start Anki while holding shift), and it persists.
I also tried restarting my computer with the same luck.

Also, it doesn’t deppend on the deck I’m reviewing, or even the card (the same card can go with or without flickering at different times, and the flicker duration varies randomly).

Also, it neither deppends on whether I use the mouse or the hotkeys for reviewing.

…and the console gives no errors when this happens.

Anyway, I’m not sure if anyone else has encountered the same issue upon update, or if anyone has any idea about how to solve it, but any help would be really appreciated.

For most of my decks it’s not too much of a deal, since cards are mostly white, but I have some decks with big chunks of color (e.g. the WaniKani Ultimate 2) that make the issue really noticeable.

Thanks in advance!

PS: I guess it has something to do with recent changes on the rendering process of the cards (since I also noticed minor changes in the handling of JS), but don’t really know more. I guess it could be solved by holding the previous image until the next one is fully loaded istead of dropping it and waiting in blank (I’m thinking persistence of vision), but I don’t know if that’s an easy fix code-wise.


Loosely tracked on rework reviewer.ts · Issue #1120 · ankitects/anki · GitHub

Yes same problem here. I can’t believe errors like these slip through. This is really bothersome and something really apparent! How could they not have noticed? I’m getting tired of this.

I will downgrade to 2.1.40 - seems like the only choice atm and stay there until I finish another 45 levels of wanikani. Maybe one day I give an Anki update another try :sweat_smile: Who knows, maybe they will fix that stupidly annoying bug by then?

I suggest you to uninstall Anki and look for a better and cheaper alternative over there instead. I’m pretty sure you will find thousands.

Have a nice day :wave:

:sweat_smile: Anki is really awesome and I’ve already donated a sum towards the project. That’s why this is so heartbreaking @cqg: we all love Anki and probably spend a lot of time with it. Bugs like the one metioned above doesn’t make things easier unfortunately.

I apologize in case I’ve been too harsh before, but the only thing I want is to see the project succeed :slightly_smiling_face: :+1:

1 Like

I’ve seen very few projects so responsive to bug reports like this one. In my short experience here, most of the bug reports, if they’re correctly reported and 100% reproducible, gets a fix within a few days. Devs are also very open minded to suggestions, I’ve personally seen a few of mine being implemented just one day after asking for it.

I’m pretty sure if this bug hasn’t been addressed it’s just because it’s not easy to reproduce or to fix; maybe you can help (please check the link above)


@marvinme123 As you can see in the first reply, they did notice it. But just to be clear, it’s not that much of an issue with most decks since they’re mostly white, and also, for what I’ve seen in the github issue, it doesn’t seem trivial to solve (and they are altogether redesigning the reviewer, so there’s quite a choice in deciding whether it’s even worth to try and fix minor bugs in something that will be deprecated anyways).

So, what I mean is, let’s at least be kind to the devs who are giving us this for free.


There have already been some updates to the reviewing code in the 2.1.45 betas. Can you reproduce the issue with the latest beta?

First time opening the 2.1.45rc for Mac resulted in a crash for me. The second time it opened fine.

The reviewer is working smooth, though!!
The flickering is gone.