Version 2.1.49 Not responding

I’d been using 2.0.52 (and earlier) without problems for years but at the start of this semester I upgraded to 2.1.49 and it has not been pleasurable. The one insurmountable problem that recurs very frequently, about every second time I start Anki after a successful opening, is that either or both the Add window or the Browse window open with no contents and “Not responding” in the title bar.
I have several add-ons installed and wonder whether this is a known issue with any of them. I haven’t found any in the description of each add-on.
I have uninstalled the add-ons individually to try to find a culprit but the results are inconsistent.
I have been unable to find any pattern or activity that causes this behaviour.
I’m running Qt 5.14.2 but don’t know how to change it to Qt6 as has been discussed in other threads or whether this would help. I downloaded the installation package and installed it. I assume that if I did the same again it might be Qt 6, or would it?
Every time I shut Anki down after it is non-responsive there is 1 more instance of mpv.exe active in Task Manager but I suppose I should expect this.
If it helps I’m using: Windows 10 Pro
Version: 20H2
Installed on: ‎27/‎04/‎2021
OS build: 19042.1586
Windows Feature Experience Pack 120.2212.4170.0
Any suggestions on how to solve this (or providing the group with more information) would be appreciated as I’m seriously considering abandoning all the work I’ve done in v2.1 and returning to 2.0 as the current situation is unworkable.
Some additional information I found when I ran anki-console at the cmd prompt is that there appears to be errors in some of the lines:

  • add-on should import json directly, not from anki.utils (I assume add-on 109531687)
  • add-on should import json directly, not from anki.utils (I assume add-on 723520343)
    addons21\1374772155\‘byName’ is deprecated: please use ‘by_name’
    conf key imgocc should be fetched with col.get_config(), and saved with col.set_config()
    Not found: ‘_anki/js/vendor/protobuf.min.js’
    Not found: ‘_anki/js/vendor/protobuf.min.js’
    JS error /_anki/pages/graphs.js:5 Uncaught Error: Cannot require(d3) at runtime.
    JS error qrc:/review_heatmap/web/review-heatmap.js:111 Uncaught TypeError: CalHeatMap is not a constructor
    gettext _() is deprecated: Add Image Occlusion (Ctrl+Shift+O)

I’ve deleted the review-heatmap add-on but I’ve still got the problem. I use the image occlusion often so I need that unless there is a better version.


Please follow the troubleshooting steps in When problems occur - Frequently Asked Questions. Does the issue occur with add-ons disabled?

dae, thanks for the advice. Today it’s working so I am reluctant to change anything as I have a mid-term test this Friday. Next time it happens I’ll post the results of trying it with the add-ons disabled. I think I’ve tried this before as well as uninstalling each one and testing to find out which add-on is problematic but the results were inconsistent.
However, next time I have a problem I’ll post the results of your suggestion.

After a few days of normal use once I rebooted my laptop the Add window has never worked again. The Browse window does not have the same problem.
I have tried restarting while holding the Shift key to disable the add-ons but the Add window continues to fail.
I have uninstalled every add-on individually, restarting and retesting after removing each one, and deleting the instance of mpv.exe that remains in the Task Manager after each application crash. I now have Anki with no add-ons but still a non functioning Add window.
There aren’t any errors or warnings when I run anki-console. So that I don’t take up too much space, I’ve only copied the last few lines here:
[9936] LOADER: callfunction returned…
[9936] LOADER: extracted pyimod03_importers
[9936] LOADER: callfunction returned…
[9936] LOADER: Installing PYZ archive with Python modules.
[9936] LOADER: PYZ archive: PYZ-00.pyz
[9936] LOADER: Running
[9936] LOADER: Running
[9936] LOADER: Running
[9936] LOADER: Running
[9936] LOADER: Running
[9936] LOADER: Running
[9936] LOADER: Running
[9936] LOADER: Running

What else can I try?

I’ve also tried installing version 2.1.51 with no effect on the problem so I’ve reverted to 2.1.49.

If you switch between multiple monitors it’s possible it’s displayed off screen. You can rename your prefs21.db file while Anki is closed to forget all window positions.

Thanks Damien. The problem isn’t that the Add window isn’t visible on the screen (I do have two monitors) but rather that the window opens with no contents and “Not responding” in the title bar. However, I followed your suggestion and it solved my problem, so I guess there was some sort of corruption in the prefs21.db file. Thanks for your help.