Utf8Error when checking database

I got this error when I used the “check database” function under the tools menu.
DBError { info: “Other(Utf8Error { valid_up_to: 339, error_len: Some(1) })”, kind: Other }

Also, I got this when I try to check media.
Anki 2.1.35 (84dcaa86) Python 3.8.0 Qt 5.14.2 PyQt 5.14.2
Platform: Windows 10
Flags: frz=True ao=False sv=1
Add-ons, last update check: 2020-10-19 09:32:01

Caught exception:
Traceback (most recent call last):
File “aqt\taskman.py”, line 87, in _on_closures_pending
File “aqt\taskman.py”, line 59, in
File “aqt\mediacheck.py”, line 81, in _on_finished
File “concurrent\futures_base.py”, line 432, in result
File “concurrent\futures_base.py”, line 388, in __get_result
File “concurrent\futures\thread.py”, line 57, in run
File “aqt\mediacheck.py”, line 70, in _check
File “anki\media.py”, line 184, in check
File “anki\rsbackend_gen.py”, line 185, in check_media
File “anki\rsbackend.py”, line 267, in _run_command
anki.rsbackend.DBError: DBError { info: “Other(Utf8Error { valid_up_to: 339, error_len: Some(1) })”, kind: Other }

I’ve tried launchin anki with shift hold down but the errors still persist.
Is there any way to fix this?

Windows 10 Build 19041 Home
Anki Version 2.1.35

Please try removing your collection.media.db file: https://anki.tenderapp.com/kb/problems/databaseerror-database-disk-image-is-malformed-when-syncing

Thanks for the reply. Unfortunately the same error persists even after I removed collection.media.db2 and restarted Anki. Is there anything else I can try? Please let me know if there is any other information I can provide.

It sounds like the issue is in your notes, rather than the media DB. A fix for this is in the development code, and a new beta should hopefully be out in a week or two.


A new beta is now available: https://betas.ankiweb.net/#/