Unable to Sync Scheduling Changes

I’m currently trying to sync scheduling changes between AnkiDroid and my Desktop version. To do this, I use AnkiDroid (where I typically do reps) > Export Collection > Include Scheduling as an .apkg. I do not include media. However, Desktop Anki is now giving an error:
“Notes found in file: 8030
Notes skipped, as they’re already in your collection: 8030.”

That is to say, all of the cards are being flagged as already in the collection, skipped, and the scheduling is not updated. I’ve already tried the following:
-Updating to version 2.1.36
-Using back-ups collections
-Re-installing Anki
-Installing Anki on a different computer

None of the above have fixed the issue. Additionally, here are some notes about how I use Anki, in case that might help diagnose the problem (though I’ve been doing this cycle since April, so it is unlikely to be the source of the problem):

  • I use Desktop Anki to add new cards
  • I export these decks, including new cards, to AnkiDroid, where I usually do reps.
  • I do not add new cards using AnkiDroid
  • When I reach a certain amount of new Mined vocabulary from reading sources, I export the scheduling of my decks from AnkiDroid to Desktop Anki, so that I can add the new cards.

My phone has issues that mean I can’t Sync to AnkiWeb directly for about a year, but it has not been an issue until now. I realize the process I use isn’t as efficient as fixing AnkiDroid, but that probably involves getting a new phone.

Any help would be appreciated.

When moving your data between devices you need to use a collection package. https://docs.ankiweb.net/#/exporting?id=packaged-decks

Alright, so when I go to export in AnkiDroid it gives the following dialog:

"Export collection as apkg file?

[ ] Include Scheduling
[ ] Include Media"

The output of this will be a collection.apkg as specified in your link.

I’m guessing a recent update has made these collection.apkg files no longer adequate for scheduling changes? I have record of using .apkg files to update my scheduling from April 21 to October 5 without issue, so the need to use a .colkpg has not always been the case. This also does not explain why using older Anki versions (I was using 2.1.15 previously before this issue came up) no longer works when it has worked without issue in the past.

When I import a file called exactly ‘collection.apkg’, it works correctly. Is your file called something else? And if so, are you renaming it, or is AnkiDroid naming it something else?

The file is named “collection.apkg” when exported, and subsequently imported. Trying the fresh install on a new computer, this was the filename. Looks like the filename was “collection (1).apkg” when trying on my regular computer because I forgot to clear the last download. Both resulted in the same error, though.

I was able to get around the issue for now by simply exporting/importing the entire collection, including scheduling and media. This is much more time-consuming though (and also requires that I keep extra space available on my phone) so I don’t see it as a permanent solution.

I’m afraid I can not reproduce the issue - importing ‘collection.apkg’ asks me to confirm overwriting, and I do not receive a message about the number of cards imported, which should only appear when importing a non-collection package. Media shouldn’t need to be included.

@David I presume you’re not able to reproduce this with the latest AnkiDroid?