Importing apkg Error 500 Upgrade to v3 Scheduler

Hi,

I’m using Ankidroid v 2.17.6

  1. I logged into Ankiweb and went through the scheduler update.

  2. I am able to synchronize Ankidroid OK.

  3. I downloaded an .apkg and want to import it into Ankidroid but when I do I get the error “500 Your collection needs to be upgraded to the v3 scheduler. Please selecr Learn More before proceeding.” (I don’t see a Learn More)

I am also open to importing the .apkg into AnkiWeb but don’t see an Import option.

Thank you!!!

Mark

Debug info:

AnkiDroid Version = 2.17.6 (568538896be943818ca793dd2635822265712def)

Backend Version = 0.1.34-anki23.12.1 (23.12.1 1a1d4d5419c6b57ef3baf99c9d2d9cf85d36ae0a)

Android Version = 12 (SDK 32)

ProductFlavor = full

Manufacturer = Google

Model = Pixel 3a

Hardware = sargo

Webview User Agent = Mozilla/5.0 (Linux; Android 12; Pixel 3a Build/SQ3A.220605.009.A1; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/102.0.5005.78 Mobile Safari/537.36

Update your AnkiDroid

Then check database

1 Like

Thanks, I was afraid you were going to say that.

When I try to install a new apk, it prompts me to upgrade which is correct. Then when I say yes, “App not installed as package conflicts with an existing package”.

I’m on LineageOS. I have never seen this before. Any idea?

No clue, but deleting the previous package version won’t damage your deck, just sync your deck before deleting

Then in the new package/version, just log in and sync

1 Like

OK, so I have version 2.18.3 now installed and I am getting the same message when I try to import a .apkg

“500 Your collection needs to be upgraded to the v3 scheduler. Please selecr Learn More before proceeding.” (I don’t see a Learn More)

What else could it be?

Is there a way to import the .apkg into Ankiweb? Then I could just do the import there.

Thanks!

Mark

Try the 3 dots on top-right and Check Database

Try Settings > Advanced and see if the v3 scheduler button is there (shouldn’t be there anymore, but just in case)

Another option would be importing in your Anki Desktop and syncing

1 Like

Can you check if .colpkg format works? It worked for someone else.

No, there’s no way to import into AnkiWeb.

Can you check if .colpkg format works?

I recommend against trying to import a single deck as a colpkg, as was suggested. That will overwrite your entire collection.